Skip to content

Macro Placement Element

Class full path: NemAll_Python_BasisElements.MacroPlacementElement

Bases: BasisElement, AllplanElement

Implementation of the macro placement element

Attributes

MacroPlacementProperties: MacroPlacementProperties property writable

Get the macro placement properties

Functions

GetArchitectureElementsList()

Get the architecture elements

Returns:

Type Description
list

Architecture elements

GetAttributesList()

Get the attributes list

Returns:

Type Description
List[AttributeSet]

Attributes list

GetFixtureElementsList()

Get the fixture elements

Returns:

Type Description
list

Fixture elements

GetLibraryElementsList()

Get the library elements

Returns:

Type Description
list

Library elements

GetMacro()

Get the corresponding macro definition

Returns:

Type Description
MacroElement

Macro definition element

GetMacroPlacementProperties()

Get the macro placement properties

Returns:

Type Description
MacroPlacementProperties

MacroPlacement properties

GetReinforcementList()

Get the reinforcement elements

Returns:

Type Description
list

Reinforcement elements

SetMacroPlacementProperties(macroPlacementProp)

Set the macro placement properties

Parameters:

Name Type Description Default
macroPlacementProp MacroPlacementProperties

MacroPlacement properties

required

__init__ overload

__init__()

Initialize

__init__(commonProp, macroPlacementProp, macro, reinforcementList, libraryElementList=[], architectureElementsList=[], fixtureElementsList=[])

Constructor

Parameters:

Name Type Description Default
commonProp CommonProperties

Common properties

required
macroPlacementProp MacroPlacementProperties

MacroPlacement properties

required
macro object

Macro definition element

required
reinforcementList list

Reinforcement elements

required
libraryElementList list

Library elements list

[]
architectureElementsList list

Architecture elements list

[]
fixtureElementsList list

Fixture elements list

[]
__init__(placement)

Copy constructor

Parameters:

Name Type Description Default
placement MacroPlacementElement

Placement to copy

required

__repr__()

Convert to string