Macro Slide Properties
Class full path: NemAll_Python_BasisElements.MacroSlideProperties
Implementation of the macro slide element properties
Attributes
EndScaleRange: float
property
writable
Get the Start reference scale of slide
OffsetOfReferencePoint1: NemAll_Python_Geometry.Vector3D
property
writable
Get the First offset value to reference point
OffsetOfReferencePoint2: NemAll_Python_Geometry.Vector3D
property
writable
Get the Second offset value to reference point
ReferencePoint: NemAll_Python_Geometry.Point3D
property
writable
Get the Reference point of this slide
ResizeSettingVx: CombinationType
property
writable
Get the Resize setting for x direction
ResizeSettingVy: CombinationType
property
writable
Get the Resize setting for y direction
ResizeSettingVz: CombinationType
property
writable
Get the Resize setting for z direction
StartScaleRange: float
property
writable
Get the Start reference scale of slide
Type: MacroSlideType
property
writable
Get the Type of macro slide
VisibilityGeo2D: bool
property
writable
Get the Geometry 2D visibility of slide
VisibilityGeo3D: bool
property
writable
Get the Geometry 3D visibility of slide
VisibilityLayerA: bool
property
writable
Get the Layer A visibility of slide
VisibilityLayerB: bool
property
writable
Get the Layer B visibility of slide
VisibilityLayerC: bool
property
writable
Get the Layer C visibility of slide
Functions
__eq__(prop)
equal operator
Parameters:
Name | Type | Description | Default |
---|---|---|---|
prop
|
MacroSlideProperties
|
MacroSlideProperties to compare |
required |
Returns:
Type | Description |
---|---|
bool
|
true if they are equal, false otherwise |
__init__
overload
__init__()
Initialize
__init__(element)
Copy constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
element
|
MacroSlideProperties
|
Element to copy |
required |
__repr__()
Convert to string