Macro Slide Type
Class full path: NemAll_Python_BasisElements.MacroSlideType
Bases: IntEnum
Definition of the macro slide type
eGeometry : Macro slide has type geometry eCode : Macro slide has type code eReinforcement : Macro slide has type reinforcement eReport : Macro slide has type report eUndergroundCadaster: Macro slide has type underground cadaster eExtension : Macro slide has type extension
Attributes
eCode = 1
class-attribute
instance-attribute
eExtension = 5
class-attribute
instance-attribute
eGeometry = 0
class-attribute
instance-attribute
eReinforcement = 2
class-attribute
instance-attribute
eReport = 3
class-attribute
instance-attribute
eUndergroundCadaster = 4
class-attribute
instance-attribute
Functions
__getitem__(key)
get the item for a key
Parameters:
Name | Type | Description | Default |
---|---|---|---|
key
|
str | int | float
|
value key |
required |
Returns:
Type | Description |
---|---|
MacroSlideType
|
value for the key |