Pattern Curve Alignment
Class full path: NemAll_Python_BasisElements.PatternCurveAlignment
Bases: IntEnum
Pattern curve alignment types of the pattern curve property
Attributes
eCenter = 1
class-attribute
instance-attribute
eLeft = 0
class-attribute
instance-attribute
eRight = 2
class-attribute
instance-attribute
Functions
__getitem__(key)
get the item for a key
Parameters:
Name | Type | Description | Default |
---|---|---|---|
key
|
str | int | float
|
value key |
required |
Returns:
Type | Description |
---|---|
PatternCurveAlignment
|
value for the key |