Pattern Curve Intersection Type
Class full path: NemAll_Python_BasisElements.PatternCurveIntersectionType
Bases: IntEnum
Pattern intersection types of the pattern curve property
Attributes
eDisabled = 0
class-attribute
instance-attribute
eJoint = 2
class-attribute
instance-attribute
eMiter = 1
class-attribute
instance-attribute
eSeamless = 3
class-attribute
instance-attribute
Functions
__getitem__(key)
get the item for a key
Parameters:
Name | Type | Description | Default |
---|---|---|---|
key
|
str | int | float
|
value key |
required |
Returns:
Type | Description |
---|---|
PatternCurveIntersectionType
|
value for the key |