Pattern Curve Properties
Class full path: NemAll_Python_BasisElements.PatternCurveProperties
PatternCurveProperties class
Attributes
AlignmentType: None
property
Property for alignment type
:type: None
Height: None
property
Property for height of pattern
:type: None
IntersectionType: None
property
Property for intersection type
:type: None
IsDrawReferenceCurve: None
property
Property for draw reference curve state
:type: None
IsLockedToCorner: None
property
Property for locked to corner state
:type: None
IsMirrorPattern: None
property
Property for mirror pattern state
:type: None
IsScaleDependent: None
property
Property for scale dependent
:type: None
PatternID: None
property
Property for pattern ID
:type: None
Width: None
property
Property for width of pattern
:type: None
Functions
__eq__(prop)
equal operator
Parameters:
Name | Type | Description | Default |
---|---|---|---|
prop
|
PatternCurveProperties
|
PatternCurveProperties to compare |
required |
Returns:
Type | Description |
---|---|
bool
|
true if they are equal, false otherwise |
__init__()
Initialize
__repr__()
Convert the list to a string
Returns:
Type | Description |
---|---|
str
|
List values as string |