Pattern Properties
Class full path: NemAll_Python_BasisElements.PatternProperties
Implementation of the pattern properties
Attributes
BackgroundColor: ARGB
property
writable
Get the background color
IsScaleDependent: bool
property
writable
Get the scale dependent state
PatternID: int
property
writable
Get the pattern ID
PlacementType: PlacementType
property
writable
Get the placement type
ReferencePoint: NemAll_Python_Geometry.Point2D
property
writable
Get the reference point
RotationAngle: NemAll_Python_Geometry.Angle
property
writable
Get the rotation angle
UseBackgroundColor: bool
property
writable
Get the use background color state
UseReferencePoint: bool
property
writable
Get the use reference point state
XScalingFactor: float
property
writable
Get the scaling factor in x direction
YScalingFactor: float
property
writable
Get the scaling factor in y direction
Functions
SetBackgroundColorBGR(value)
Set the background color
Parameters:
Name | Type | Description | Default |
---|---|---|---|
value
|
int
|
Color value as BGR |
required |
SetBackgroundColorIRGB(value)
Set the background color
Parameters:
Name | Type | Description | Default |
---|---|---|---|
value
|
int
|
Color value as IRGB |
required |
__eq__(prop)
equal operator
Parameters:
Name | Type | Description | Default |
---|---|---|---|
prop
|
PatternProperties
|
PatternProperties to compare |
required |
Returns:
Type | Description |
---|---|
bool
|
true if they are equal, false otherwise |
__init__
overload
__init__()
Initialize
__init__(element)
Copy constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
element
|
PatternProperties
|
Element to copy |
required |
__repr__()
Convert to string