Placement Type
Class full path: NemAll_Python_BasisElements.PlacementType
Bases: IntEnum
Definition of the pattern placement type
eOutsideFitting: Outside fitting eFitting : Fitting eInsideFitting : Inside fitting
Attributes
eFitting = 1
class-attribute
instance-attribute
eInsideFitting = 2
class-attribute
instance-attribute
eOutsideFitting = 0
class-attribute
instance-attribute
Functions
__getitem__(key)
get the item for a key
Parameters:
Name | Type | Description | Default |
---|---|---|---|
key
|
str | int | float
|
value key |
required |
Returns:
Type | Description |
---|---|
PlacementType
|
value for the key |