Section Along Path Clipping Path Properties
Class full path: NemAll_Python_BasisElements.SectionAlongPathClippingPathProperties
Clipping path properties
Attributes
BottomLevel: float
property
writable
Get the BottomLevel for section Vertical or Horizontal_From_Top
ClippingPathViewProperties: SectionAlongPathClippingPathViewProperties
property
writable
Get the SectionAlongPathClippingPathViewProperties
EndCoord: float
property
writable
Get the EndCoord value
IsChangeViewDirectionOn: bool
property
writable
Get the IsChangeViewDirectionOn status : ON/OFF
IsClippingLineOn: bool
property
writable
Get the Is clipping path line on
IsHeightFromElementOn: bool
property
writable
Get the IsHeightFromElementOn status : ON/OFF
SectionIdentifier: str
property
writable
Get the Section identifier
StartCoord: float
property
writable
Get the StartCoord value
StationingEnd: float
property
writable
Get end stationing
StationingStart: float
property
writable
Get start stationing
TopLevel: float
property
writable
Get the TopLevel for section Vertical or Horizontal_From_Bottom
Functions
GetClippingPathGeometryTolerance()
staticmethod
Access tolerances
Returns:
Type | Description |
---|---|
float
|
ClippingPathGeometryTolerance |
GetPathLength()
Get length of path
GetResultPathLength()
Get length of the part of path limited by EndCoord and StartCoord
RestrictEmptySectionId()
__init__
overload
__init__(bInitFromSTW=False)
constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
bInitFromSTW
|
bool
|
|
False
|
__init__(B)
copy constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
B
|
SectionAlongPathClippingPathProperties
|
|
required |