Section Along Path Element
Class full path: NemAll_Python_BasisElements.SectionAlongPathElement
Bases: BasisElement
, AllplanElement
Implementation of the section along path element
Functions
__init__
overload
__init__(sectionAlongPathProperties, sectionPathElement)
Default constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
sectionAlongPathProperties
|
SectionAlongPathProperties
|
Section along path properties |
required |
sectionPathElement
|
BaseElementAdapter
|
Section path element |
required |
__init__(sectionAlongPathProperties, sectionPath, comProp)
Constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
sectionAlongPathProperties
|
SectionAlongPathProperties
|
Section along path properties |
required |
sectionPath
|
Path2D
|
Section path |
required |
comProp
|
CommonProperties
|
Common properties |
required |
__init__(element)
Copy constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
element
|
SectionAlongPathElement
|
Element to copy |
required |