Section Along Path Format Properties
Class full path: NemAll_Python_BasisElements.SectionAlongPathFormatProperties
Format properties
Attributes
AdjacentEdgeTypeSwitcher: int
property
writable
Get the 0=material, 1=surface, we set a tooltip and description in palette
BoundaryLineColor: int
property
writable
Get the Border: Boundary Line color index
BoundaryLineLayer: int
property
writable
Get the Border: Boundary Line Layer number
BoundaryLineLayerKenner: int
property
writable
Gets layer kenner for Boundary Line
Sets layer kenner for Boundary Line
BoundaryLinePen: int
property
writable
Get the Border: Boundary Line pen index (0== not used)
BoundaryLineType: int
property
writable
Get the Border: Boundary Line stroke index
EdgesVisibility: bool
property
writable
Get the Outer edges/All edges Visible 0, 1
EliminationAngle: float
property
writable
Get the Angle of the Adjacent Edge elimination, //always in degree
IsBetweenDifferentSurfacesOn: bool
property
writable
Get the Adjacent Edge Between Different Surfaces
IsBoundaryLineColorFromLayer: bool
property
writable
Get the Border: IsBoundaryLineColorFromLayer
IsBoundaryLinePenFromLayer: bool
property
writable
Get the Border: IsBoundaryLinePenFromLayer
IsBoundaryLineTypeFromLayer: bool
property
writable
Get the Border: IsBoundaryLineTypeFromLayer
IsBoundaryLineVisible: bool
property
writable
Get the BoundaryLine visibility
IsEliminationOn: bool
property
writable
Get the Adjacent Edge elimination
IsSectionLineColorFromLayer: bool
property
writable
Get the Section: IsSectionLineColorFromLayer
IsSectionLinePenFromLayer: bool
property
writable
Get the Section: IsSectionLinePenFromLayer
IsSectionLineThicknessVisible: bool
property
writable
Get the SectionLineThickness visibility
IsSectionLineTypeFromLayer: bool
property
writable
Get the Section: IsSectionLineTypeFromLayer
IsSurfaceFromObjectOn: bool
property
writable
Get the Display Surface From Object
Overhang: float
property
writable
Get the Overhang
SectionLineColor: int
property
writable
Get the Section: Boundary Line color index
SectionLineLayer: int
property
writable
Get the Section: Section Line Layer number
SectionLineLayerKenner: int
property
writable
Gets layer kenner for Section Line
Sets layer kenner for Section Line
SectionLinePen: int
property
writable
Get the Section: Boundary Line pen index (0== not used)
SectionLineType: int
property
writable
Get the Section: Boundary Line stroke index
Functions
GetEliminationAngleTolerance()
staticmethod
Access tolerances
Returns:
Type | Description |
---|---|
float
|
elimination angle tolerance |
GetOverhangTolerance()
staticmethod
Access tolerances
Returns:
Type | Description |
---|---|
float
|
overhang tolerance |
__init__
overload
__init__(bInitFromSTW=False)
constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
bInitFromSTW
|
bool
|
|
False
|
__init__(B)
copy constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
B
|
SectionAlongPathFormatProperties
|
|
required |