Section Along Path General Section Properties
Class full path: NemAll_Python_BasisElements.SectionAlongPathGeneralSectionProperties
General section properties
Attributes
ElevationSpecifications: SectionAlongPathElevationSpecifications
property
writable
Get the SectionAlongPathElevationSpecifications
FormatProperties: SectionAlongPathFormatProperties
property
writable
Get the SectionAlongPathFormatProperties
LabelingStripSetting: SectionAlongPathLabelingStripSetting
property
writable
Get the SectionAlongPathLabelingStripSetting
Offset_X: float
property
writable
Get the X coordinate of left bottom corner
Offset_Y: float
property
writable
Get the Y coordinate of left bottom corner
SectionLabelingProperties: SectionAlongPathSectionLabelingProperties
property
writable
Get the SectionAlongPathSectionLabelingProperties
SectionViewProperties: SectionAlongPathSectionViewProperties
property
writable
Get the SectionAlongPathSectionViewProperties
Functions
GetOffset()
Get offset
Returns:
Type | Description |
---|---|
bool
|
tuple(true if it was read from 55th element, |
float
|
X coordinate of section's left bottom corner, |
float
|
Y coordinate of section's left bottom corner) |
IsOffsetValid()
Get offset state
SetOffset(dOffset_X, dOffset_Y)
Set offset
Parameters:
Name | Type | Description | Default |
---|---|---|---|
dOffset_X
|
float
|
X coordinate of section's left bottom corner |
required |
dOffset_Y
|
float
|
Y coordinate of section's left bottom corner |
required |
__init__
overload
__init__(bInitFromSTW=False)
constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
bInitFromSTW
|
bool
|
|
False
|
__init__(B)
copy constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
B
|
SectionAlongPathGeneralSectionProperties
|
|
required |