Section Along Path Labeling Strip Setting
Class full path: NemAll_Python_BasisElements.SectionAlongPathLabelingStripSetting
Labeling strip settings
Attributes
Distance_1: float
property
writable
Get the Distance 1 in mm
Distance_2: float
property
writable
Get the Distance 2 in mm
Distance_3: float
property
writable
Get the Distance 3 in mm
Distance_4: float
property
writable
Get the Distance 4 in mm
Distance_5: float
property
writable
Get the Distance 5 in mm
Distance_6: float
property
writable
Get the Distance 6 in mm
Distance_7: float
property
writable
Get the Distance 7 in mm
HeightLines_Color: int
property
writable
Get the Height lines color
HeightLines_HeightZone: int
property
writable
Get the Height lines height zone
HeightLines_LineType: int
property
writable
Get the Height lines line type
HeightLines_Pen: int
property
writable
Get the Height lines pen
HeightLines_ProfileZone: int
property
writable
Get the Height lines profile zone
HeightLines_Splay: int
property
writable
Get the Height lines splay
HeightLines_StationZone: int
property
writable
Get the Height lines station zone
HeightText_Color: int
property
writable
Get the Height text color
HeightText_Distance: float
property
writable
Get the Height text distance in mm
HeightText_Height: float
property
writable
Get the Height text height in mm
HeightText_Pen: int
property
writable
Get the Height text pen
HeightText_Precision: int
property
writable
Get the Height text decimals
HeightText_Width: float
property
writable
Get the Height text width in mm
ProfileAx_Color: int
property
writable
Get the Profile axis color
ProfileAx_LineType: int
property
writable
Get the Profile axis line type
ProfileAx_Pen: int
property
writable
Get the Profile axis pen
ProfileFrame_Color: int
property
writable
Get the Profile frame color
ProfileFrame_LineType: int
property
writable
Get the Profile frame line type
ProfileFrame_Pen: int
property
writable
Get the Profile frame pen
ProfileLine_Color: int
property
writable
Get the Profile line color
ProfileLine_LineType: int
property
writable
Get the Profile line line type
ProfileLine_Muster: int
property
writable
Get the Profile line pattern
ProfileLine_Pen: int
property
writable
Get the Profile line pen
RefererenzeHeight_Distance: float
property
writable
Get the Reference height text distance in mm
RefererenzeHeight_Height: float
property
writable
Get the Reference height text height in mm
RefererenzeHeight_TextColor: int
property
writable
Get the Reference height text color
RefererenzeHeight_TextPen: int
property
writable
Get the Reference height text pen
RefererenzeHeight_TextPrecision: int
property
writable
Get the Reference height text decimals
RefererenzeHeight_Width: float
property
writable
Get the Reference height text width in mm
StationText_Color: int
property
writable
Get the Station text color
StationText_Distance: float
property
writable
Get the Station text distance in mm
StationText_Height: float
property
writable
Get the Station text height in mm
StationText_Pen: int
property
writable
Get the Station text pen
StationText_Precision: int
property
writable
Get the Station text decimals
StationText_Width: float
property
writable
Get the Station text width in mm
Functions
__init__
overload
__init__(bInitFromSTW=False)
constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
bInitFromSTW
|
bool
|
|
False
|
__init__(B)
copy constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
B
|
SectionAlongPathLabelingStripSetting
|
|
required |