Section Along Path Scale Properties
Class full path: NemAll_Python_BasisElements.SectionAlongPathScaleProperties
Scale properties
Attributes
ScaleFactorX: float
property
writable
Get the resizing factor X in Longitudinal direction
ScaleFactorY: float
property
writable
Get the resizing factor Y in Transversal direction
Functions
GetScaleFactorTolerance()
staticmethod
Access tolerance
Returns:
Type | Description |
---|---|
float
|
scale factor tolerance |
__init__
overload
__init__(bInitFromSTW=False)
constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
bInitFromSTW
|
bool
|
|
False
|
__init__(B)
copy constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
B
|
SectionAlongPathScaleProperties
|
|
required |