Section Along Path Section Labeling Properties
Class full path: NemAll_Python_BasisElements.SectionAlongPathSectionLabelingProperties
Section labeling properties
Attributes
HeadingText: str
property
writable
Get the HeadingText "longitudinal profile", "transversal profile", "elevation", "section", "Unfold", . and "none" (expandable)
HeadingTextParameters: SectionAlongPathTextParameterProperties
property
writable
Get the SectionAlongPathTextParameterProperties
IsHeadingOn: bool
property
writable
Get the IsHeadingOn
IsScaleOn: bool
property
writable
Get the IsScaleOn
LabelingOffset: float
property
writable
Get the Distance of the labeling from its content's min/max box
LabelingPosition: int
property
writable
Get the Position of the labeling with respect to its content's min/max box
LabelingsDistance: float
property
writable
Get the Distance between scale text and heading text
ScaleTextParameters: SectionAlongPathTextParameterProperties
property
writable
Get the SectionAlongPathTextParameterProperties
Classes
SAAPLabelingPosition_Enum
Bases: IntEnum
enum for Reference point position
Nothing: Calculated like before this implementation
Functions
__getitem__(key)
get the item for a key
Parameters:
Name | Type | Description | Default |
---|---|---|---|
key
|
str | int | float
|
value key |
required |
Returns:
Type | Description |
---|---|
SAAPLabelingPosition_Enum
|
value for the key |
Functions
__init__
overload
__init__(bInitFromSTW=False)
constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
bInitFromSTW
|
bool
|
|
False
|
__init__(B)
copy constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
B
|
SectionAlongPathSectionLabelingProperties
|
|
required |