Section Along Path Section View Properties
Class full path: NemAll_Python_BasisElements.SectionAlongPathSectionViewProperties
Section view properties
Attributes
Horizont: float
property
writable
Get the Horizon
IsElementedgesDisplayed: bool
property
writable
Get the Is element edges displayed
IsElementedges_BottomLabeling: bool
property
writable
Get the Is element edges bottom labeling
IsElementedges_MiddleLabeling: bool
property
writable
Get the Is element edges middle labeling
IsElementedges_TopLabeling: bool
property
writable
Get the Is element edges top labeling
IsHorizontalPositionPointDisplayed: bool
property
writable
Get the Is horizontal position point displayed
IsHorizontalPositionPoint_BottomLabeling: bool
property
writable
Get the Is horizontal position point bottom labeling
IsHorizontalPositionPoint_MiddleLabeling: bool
property
writable
Get the Is horizontalPositionPoint_Middle labeling
IsHorizontalPositionPoint_TopLabeling: bool
property
writable
Get the Is horizontal position point top labeling
IsStationPointDisplayed: bool
property
writable
Get the Is station point displayed
IsStationPoint_BottomLabeling: bool
property
writable
Get the Is station point bottom labeling
IsStationPoint_MiddleLabeling: bool
property
writable
Get the Is station point middle labeling
IsStationPoint_TopLabeling: bool
property
writable
Get the Is station point_Top labeling
IsZeroAxDisplayed: bool
property
writable
Get the Is zero axis displayed
IsZeroAx_BottomLabeling: bool
property
writable
Get the Is zero Axis bottom labeling
IsZeroAx_MiddleLabeling: bool
property
writable
Get the Is zero axis middle labeling
IsZeroAx_TopLabeling: bool
property
writable
Get the Is zero Axis top labeling
LabelingType: int
property
writable
Get the LabelingType
Offset: float
property
writable
Get the Offset
Functions
GetHorizontTolerance()
staticmethod
Access tolerances
GetOffsetTolerance()
staticmethod
Access tolerances
__init__
overload
__init__(bInitFromSTW=False)
constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
bInitFromSTW
|
bool
|
|
False
|
__init__(B)
copy constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
B
|
SectionAlongPathSectionViewProperties
|
|
required |