Section General Properties
Class full path: NemAll_Python_BasisElements.SectionGeneralProperties
General section properties
Attributes
FilterProperties: None
property
Property for the filter properties
:type: None
FormatProperties: None
property
Property for the format properties
:type: None
HiddenSectionLinesProperties: None
property
Property for the hidden section line properties
:type: None
LabelingProperties: None
property
Property for the labeling properties
:type: None
PlacementAngle: None
property
Property for the placement angle
:type: None
PlacementPoint: None
property
Property for the placement point
:type: None
PlacementPointType: None
property
Property for the placement point
:type: None
ShowSectionBody: None
property
Property for the showing of the section body
:type: None
Status: None
property
Property for the drawing state
:type: None
VisibleHiddenEdgesProperties: None
property
Property for the visible and hidden edge properties
:type: None
Classes
PlacementPointPosition
Bases: IntEnum
Placement point position
Functions
__getitem__(key)
get the item for a key
Parameters:
Name | Type | Description | Default |
---|---|---|---|
key
|
str | int | float
|
value key |
required |
Returns:
Type | Description |
---|---|
PlacementPointPosition
|
value for the key |
State
Bases: IntEnum
Drawing state of the section
Functions
__getitem__(key)
get the item for a key
Parameters:
Name | Type | Description | Default |
---|---|---|---|
key
|
str | int | float
|
value key |
required |
Returns:
Type | Description |
---|---|
State
|
value for the key |
Functions
__init__
overload
__init__()
Initialize
__init__(bInitFromSTW)
constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
bInitFromSTW
|
bool
|
|
required |