Section Layer Properties
Class full path: NemAll_Python_BasisElements.SectionLayerProperties
Section layer properties
Classes
eVisibilityFilterMode
Bases: IntEnum
Visible filter mode
Functions
__getitem__(key)
get the item for a key
Parameters:
Name | Type | Description | Default |
---|---|---|---|
key
|
str | int | float
|
value key |
required |
Returns:
Type | Description |
---|---|
eVisibilityFilterMode
|
value for the key |
Functions
SetLayerProperties(iVisibilityFilterMode, bAreInvisibleLyersStored, layerIdVector)
Set the layer properties
Parameters:
Name | Type | Description | Default |
---|---|---|---|
iVisibilityFilterMode
|
int
|
Type of selected filter mode |
required |
bAreInvisibleLyersStored
|
bool
|
true -> Elements in excludedLayerList are filtered out |
required |
false
|
-> Elements in excludedLayerList are taken into consideration |
required | |
layerIdVector
|
VecUShortList
|
Elements belonging to these Layers should be filtered (excluded) from source up to flag bAreInvisibleLyersStored |
required |
__init__()
Initialize