Symbol3D Element
Class full path: NemAll_Python_BasisElements.Symbol3DElement
Bases: BasisElement
, AllplanElement
Symbol3DElement class
Functions
GetSymbol3DProperties()
Get the Symbol3D properties
Returns:
Type | Description |
---|---|
Symbol3DProperties
|
Symbol3D properties |
SetSymbol3DProperties(symbol3DProp)
Set the Symbol3D properties
Parameters:
Name | Type | Description | Default |
---|---|---|---|
symbol3DProp
|
Symbol3DProperties
|
Symbol3D properties |
required |
__init__
overload
__init__()
Initialize
__init__(commonProp, Symbol3DProp, geometryObject)
Constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
commonProp
|
CommonProperties
|
Common properties |
required |
symbol3DProp
|
Symbol3D properties |
required | |
geometryObject
|
object
|
Geometry element |
required |
__repr__()
Convert the list to a string
Returns:
Type | Description |
---|---|
str
|
List values as string |