Text Properties
Class full path: NemAll_Python_BasisElements.TextProperties
Implementation of the text properties
Attributes
Alignment: eTextAlignment
property
writable
Get the Alignment of text
BackgroundColor: int
property
writable
Get the Background color of text
ColumnSlopeAngle: NemAll_Python_Geometry.Angle
property
writable
Get the Angle of columns in [rad]
Expansion: NEM_UBYTE_t
property
writable
Get the Background color of text
Font: int
property
writable
Get the font ID
FontAngle: NemAll_Python_Geometry.Angle
property
writable
Get the Angle of characters (italic) in [rad]
HasBackgroundColor: bool
property
writable
check eHasTextBgColor property flag
return true if eHasTextBgColor is set otherwise return false
HasReferencePoint: bool
property
writable
check eHasReferencePoint property flag
return true if eHasReferencePoint is set otherwise return false
HasTextFrame: bool
property
writable
check text frame active
return true if text frame is active otherwise return false
HasTransparentBackground: bool
property
writable
check eHasTransparentBackground property flag
return true if eHasTransparentBackground is set otherwise return false
Height: float
property
writable
Get the Height of text in [mm]
IsScaleDependent: bool
property
writable
check eIsScaleDependent property flag
return true if eIsScaleDependent is set otherwise return false
IsUserModifiable: bool
property
writable
Check if user can modify text
return true if user can modify text
LineFeed: float
property
writable
Get the Line feed of text in [mm]
TextAngle: NemAll_Python_Geometry.Angle
property
writable
Get the Angle of hole text in [rad]
TextFrame: TextFrameStruct
property
writable
Get the Text frame pen, stroke color settings
TextFrameColor: int
property
writable
Get text frame color value
TextFramePen: int
property
writable
Get text frame pen value
TextFrameStroke: int
property
writable
Get text frame stroke value
Type: eTextType
property
writable
Get the Text type (0 - normal text, >1 variables textbild (itv))
Width: float
property
writable
Get the Width of text in [mm]
WrappedText: bool
property
writable
Property for text wrapping
returns true if the text is wrapped
Functions
GetRatio()
Get ration height/width
Init()
Init section properties with default values
IsDraftText()
check eDraftText property flag
return true if eDraftText is set otherwise return false
SetHasBackgroundColorAndTransparentBackgroundColor(value)
Args: value:
__eq__(prop)
equal operator
Parameters:
Name | Type | Description | Default |
---|---|---|---|
prop
|
TextProperties
|
TextProperties to compare |
required |
Returns:
Type | Description |
---|---|
object
|
true if they are equal, false otherwise |
__init__
overload
__init__()
Initialize
__init__(element)
Copy constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
element
|
TextProperties
|
Element to copy |
required |
__repr__()
Convert to string