Texture Definition
Class full path: NemAll_Python_BasisElements.TextureDefinition
TextureDefinition class
Attributes
SurfacePath: None
property
Property for surface path
:type: None
Functions
__eq__(props)
Compare operator
Parameters:
Name | Type | Description | Default |
---|---|---|---|
props
|
TextureDefinition
|
Properties to compare |
required |
Returns:
Type | Description |
---|---|
bool
|
Properties a equal: true/false |
__init__
overload
__init__()
Initialize
__init__(surfacePath)
Constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
surfacePath
|
str
|
Surface path of texture definition |
required |
__repr__()
Convert the list to a string
Returns:
Type | Description |
---|---|
str
|
List values as string |