Texture Mapping
Class full path: NemAll_Python_BasisElements.TextureMapping
Texture mapping property class
Attributes
MappingAngle: float
property
writable
Get mapping angle
MappingType: eMappingType
property
writable
Get mapping type
PhongAngle: float
property
writable
Get angle for Phong light model
ReferenceEdge: int
property
writable
Get reference edge
ReferenceFace: int
property
writable
Get reference face
UVCoordinates: list[float]
property
writable
Get UV texture mapping coordinates
UValueForIsoLines: int
property
writable
Get U count of isolines
VValueForIsoLines: int
property
writable
Get V count of isolines
XOffset: float
property
writable
Get X offset
XScale: float
property
writable
Get mapping X scale
YOffset: float
property
writable
Get Y offset
YScale: float
property
writable
Get mapping Y scale
Functions
FromSurfaceMapping(mapping)
Get the properties from the surface mapping object
Parameters:
Name | Type | Description | Default |
---|---|---|---|
mapping
|
object
|
Surface mapping |
required |
__eq__(props)
Compare operator
Parameters:
Name | Type | Description | Default |
---|---|---|---|
props
|
TextureMapping
|
Properties to compare |
required |
Returns:
Type | Description |
---|---|
bool
|
Properties a equal: true/false |
__init__
overload
__init__()
Initialize
__init__(mappingType, mappingAngle, scaleX, scaleY, offsetX, offsetY, phongAngle, refFace, refEdge)
Constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
mappingType
|
TextureMappingType
|
Mapping type |
required |
mappingAngle
|
float
|
Mapping angle |
required |
scaleX
|
float
|
Mapping scale in X-axis |
required |
scaleY
|
float
|
Mapping scale in Y-axis |
required |
offsetX
|
float
|
X offset |
required |
offsetY
|
float
|
Y offset |
required |
phongAngle
|
float
|
Angle for Phong light model |
required |
refFace
|
int
|
Reference face |
required |
refEdge
|
int
|
Reference edge |
required |
__init__(mappingType, mappingAngle, scaleX, scaleY, offsetX, offsetY, phongAngle, refFace, refEdge, uvCoords)
Constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
mappingType
|
TextureMappingType
|
Mapping type |
required |
mappingAngle
|
float
|
Mapping angle |
required |
scaleX
|
float
|
Mapping scale in X-axis |
required |
scaleY
|
float
|
Mapping scale in Y-axis |
required |
offsetX
|
float
|
X offset |
required |
offsetY
|
float
|
Y offset |
required |
phongAngle
|
float
|
Angle for Phong light model |
required |
refFace
|
int
|
Reference face |
required |
refEdge
|
int
|
Reference edge |
required |
uvCoords
|
VecDoubleList
|
UV coordinates |
required |
__init__(uvCoords)
Constructor, set the type to eUV
Parameters:
Name | Type | Description | Default |
---|---|---|---|
uvCoords
|
VecDoubleList
|
UV coordinates |
required |
__init__(element)
Copy constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
element
|
TextureMapping
|
Element to copy |
required |
__repr__()
Convert to string