Texture Mapping Type
Class full path: NemAll_Python_BasisElements.TextureMappingType
Bases: IntEnum
eCube - from each side eWall - mainly from the front view eRoof - mainly from the top view eGround - only from the top view eCylinder - Cylindrical mapping eSphere - Spherical mapping eUV - UV mapping
Attributes
eCube = 0
class-attribute
instance-attribute
eCylinder = 4
class-attribute
instance-attribute
eGround = 3
class-attribute
instance-attribute
eRoof = 2
class-attribute
instance-attribute
eSphere = 5
class-attribute
instance-attribute
eUV = 6
class-attribute
instance-attribute
eWall = 1
class-attribute
instance-attribute
Functions
__getitem__(key)
get the item for a key
Parameters:
Name | Type | Description | Default |
---|---|---|---|
key
|
str | int | float
|
value key |
required |
Returns:
Type | Description |
---|---|
TextureMappingType
|
value for the key |