Variant Type
Class full path: NemAll_Python_BasisElements.VariantType
Bases: IntEnum
Variant types of the filling property
Attributes
eVariant1 = 0
class-attribute
instance-attribute
eVariant2 = 1
class-attribute
instance-attribute
eVariant3 = 2
class-attribute
instance-attribute
eVariant4 = 3
class-attribute
instance-attribute
Functions
__getitem__(key)
get the item for a key
Parameters:
Name | Type | Description | Default |
---|---|---|---|
key
|
str | int | float
|
value key |
required |
Returns:
Type | Description |
---|---|
VariantType
|
value for the key |