View Section Element
Class full path: NemAll_Python_BasisElements.ViewSectionElement
Bases: AllplanElement
Implementation of the view section element
Attributes
DimensionElements: list
property
writable
GeneralSectionProperties: SectionGeneralProperties
property
writable
ReinforcementLabels: NemAll_Python_Reinforcement.ReinforcementLabel
property
writable
SectionDefinitionData: SectionDefinitionData
property
writable
TextElements: list
property
writable
ViewMatrix: NemAll_Python_Geometry.Matrix3D
property
writable
Functions
CreateSectionBody(doc, insertionMat, undoRedoService=None)
Create the section body
Parameters:
Name | Type | Description | Default |
---|---|---|---|
doc
|
DocumentAdapter
|
Document |
required |
insertionMat
|
Matrix3D
|
Placement matrix |
required |
undoRedoService
|
Optional[object]
|
|
None
|
DrawElement(modelElements, insertionMat, docID, asStaticPreview)
Draw eLement preview in Allplan
Parameters:
Name | Type | Description | Default |
---|---|---|---|
modelElements
|
object
|
Python object which should be drawn |
required |
insertionMat
|
Matrix3D
|
insertion matrix |
required |
docID
|
int
|
Document ID |
required |
asStaticPreview
|
bool
|
|
required |
Returns:
Type | Description |
---|---|
MinMax3D
|
Min/max box of the preview |
__init__
overload
__init__()
Initialize
__init__(param)
Args: param:
__repr__()
Convert to string