Approximation Settings
Class full path: NemAll_Python_Geometry.ApproximationSettings
Class holding approximation options.
Functions
GetDensity()
Get Density value
Returns:
Type | Description |
---|---|
float
|
density value |
GetMaxAngle()
Get Maximal Angle value
Returns:
Type | Description |
---|---|
Angle
|
maximal angle value |
GetMaxDistance()
Get MaxDistance value
Returns:
Type | Description |
---|---|
float
|
const Reference to MaxDistance value |
GetMaxLength()
Get MaxLength value
Returns:
Type | Description |
---|---|
float
|
const Reference to MaxLength value |
GetMinLength()
Get Minimal Length value
Returns:
Type | Description |
---|---|
float
|
minimal length value |
GetSegmentation()
Get Segmentation value
Returns:
Type | Description |
---|---|
int
|
const Reference to Segmentation value |
GetType()
Get Type of the settings
IsBRepTesselation()
Check whether the type of the settings is ASET_BREP_TESSELATION
Returns:
Type | Description |
---|---|
bool
|
true/false. |
IsMaxDistance()
Check whether the type of the settings is ASET_MAX_DISTANCE
Returns:
Type | Description |
---|---|
bool
|
true/false. |
IsMaxLength()
Check whether the type of the settings is ASET_MAX_LENGTH
Returns:
Type | Description |
---|---|
bool
|
true/false. |
IsSegmentation()
Check whether the type of the settings is ASET_SEGMENTATION
Returns:
Type | Description |
---|---|
bool
|
true/false. |
SetBRepTesselation(density, maxAngle, minLength, maxLength)
Set all settings for BRep3D tesselation.
Parameters:
Name | Type | Description | Default |
---|---|---|---|
density
|
float
|
new density value. |
required |
maxAngle
|
Angle
|
new maximal edge length value. |
required |
minLength
|
float
|
new minimal edge length value. |
required |
maxLength
|
float
|
new maximal angle value. |
required |
SetMaxDistance(maxDistance)
Set MaxDistance value.
Parameters:
Name | Type | Description | Default |
---|---|---|---|
maxDistance
|
float
|
new MaxDistance value. |
required |
SetMaxLength(maxLength)
Set MaxLength value.
Parameters:
Name | Type | Description | Default |
---|---|---|---|
maxLength
|
float
|
new MaxLength value. |
required |
SetSegmentation(segmentation)
Set Segmentation.
Parameters:
Name | Type | Description | Default |
---|---|---|---|
segmentation
|
int
|
new Segmentation value. |
required |
__eq__(right)
Operator ==
Parameters:
Name | Type | Description | Default |
---|---|---|---|
right
|
ApproximationSettings
|
settings to compare |
required |
Returns:
Type | Description |
---|---|
bool
|
true if settings are equal |
__init__
overload
__init__(oType=eApproximationSettingsType.ASET_SEGMENTATION, value=30.0)
Default constructor.
Other members will be set to 0. Types can be found in GeometryEnums.h
Parameters:
Name | Type | Description | Default |
---|---|---|---|
oType
|
eApproximationSettingsType
|
Type of the settings which will be set |
ASET_SEGMENTATION
|
value
|
float
|
value which will be set |
30.0
|
__init__(options)
Copy constructor.
Parameters:
Name | Type | Description | Default |
---|---|---|---|
options
|
ApproximationSettings
|
ApproximationSettings which will be copied. |
required |
__ne__(right)
Operator !=
Parameters:
Name | Type | Description | Default |
---|---|---|---|
right
|
ApproximationSettings
|
settings to compare |
required |
Returns:
Type | Description |
---|---|
bool
|
true if settings are NOT equal |