B Rep3D Builder
Class full path: NemAll_Python_Geometry.BRep3DBuilder
Builder for BRep3D
Functions
AddEdge
overload
AddEdge(edgeIdx, edgeSense, loopIdx)
Add edge to loop
Parameters:
Name | Type | Description | Default |
---|---|---|---|
edgeIdx
|
int
|
Index of already added edge |
required |
edgeSense
|
bool
|
Sense of edge |
required |
loopIdx
|
int
|
Index of loop to which edge will be added |
required |
AddEdge(curve_object, curveSense, edgeSense, loopIdx, precision)
Add edge to loop
Parameters:
Name | Type | Description | Default |
---|---|---|---|
curve_object
|
object
|
Geometry of curve |
required |
curveSense
|
bool
|
Sense of curve |
required |
edgeSense
|
bool
|
Sense of edge |
required |
loopIdx
|
int
|
Index of loop to which edge will be added |
required |
precision
|
float
|
Precision of edge |
required |
Returns:
Type | Description |
---|---|
int
|
Index of edge |
AddFace(surface_object, sense)
Add face
Parameters:
Name | Type | Description | Default |
---|---|---|---|
surface_object
|
object
|
Geometry of surface |
required |
sense
|
bool
|
Sense of surface |
required |
Returns:
Type | Description |
---|---|
int
|
Index of face |
AddLoop(faceIdx)
Add loop
Parameters:
Name | Type | Description | Default |
---|---|---|---|
faceIdx
|
int
|
Index of face to which loop will be added |
required |
Returns:
Type | Description |
---|---|
int
|
Index of face |
AddVertex
overload
AddVertex(point, edgeIdx, precision)
Add vertex to edge
Parameters:
Name | Type | Description | Default |
---|---|---|---|
point
|
Point3D
|
Geometry point |
required |
edgeIdx
|
int
|
Index of edge to which vertex will be added |
required |
precision
|
float
|
Vertex precision |
required |
Returns:
Type | Description |
---|---|
int
|
Index of vertex |
AddVertex(vertexIdx, edgeIdx)
Add vertex to edge
Parameters:
Name | Type | Description | Default |
---|---|---|---|
vertexIdx
|
int
|
Index of already added vertex |
required |
edgeIdx
|
int
|
Index of edge to which vertex will be added |
required |
CheckLoop(loopIdx)
Check whether loop topology is correct
Parameters:
Name | Type | Description | Default |
---|---|---|---|
loopIdx
|
int
|
Index of loop to check |
required |
Returns:
Type | Description |
---|---|
bool
|
Flag whether loop is topologically correct |
Complete()
Complete topology and create BRep
Returns:
Type | Description |
---|---|
BRep3D
|
Created BRep |
Init(isSolid)
Add body, region and shell
Parameters:
Name | Type | Description | Default |
---|---|---|---|
isSolid
|
bool
|
Flag whether body is solid |
required |
__init__
overload
__init__()
Initialize
__init__(element)
Copy constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
element
|
BRep3DBuilder
|
Element to copy |
required |