Clipped Swept Solid3D
Class full path: NemAll_Python_Geometry.ClippedSweptSolid3D
Representation class for solid created by extrusion of area with borders of a plane at the bottom and a plane at the top in world z - axis direction
Attributes
BottomPlane: None
property
Get and set the bottom plane as property
:type: None
RefPoint: None
property
Get and set the reference point as property
:type: None
SweptArea: None
property
Get and set the swept area as property
:type: None
TopPlane: None
property
Get and set the top plane as property
:type: None
Functions
GetBottomPlane()
Get bottom clipping plane
Returns:
Type | Description |
---|---|
Plane3D
|
Plane3D const reference |
GetRefPoint()
Get the reference point
Returns:
Type | Description |
---|---|
Point3D
|
Reference point |
GetSweptArea()
Get Swept area
Returns:
Type | Description |
---|---|
PolygonalArea2D
|
PolygonalArea2D const reference |
GetTopPlane()
Get top clipping plane
Returns:
Type | Description |
---|---|
Plane3D
|
Plane3D const reference |
IsValid()
Check if the Solid is valid
Returns:
Type | Description |
---|---|
bool
|
True if it is a valid solid |
SetBottomPlane(plane)
Set bottom clipping plane
Parameters:
Name | Type | Description | Default |
---|---|---|---|
plane
|
Plane3D
|
Plane3D const reference |
required |
SetRefPoint(refPoint)
Set reference point
Parameters:
Name | Type | Description | Default |
---|---|---|---|
refPoint
|
Point3D
|
New reference point |
required |
SetSweptArea(area)
Set Swept area
Parameters:
Name | Type | Description | Default |
---|---|---|---|
area
|
PolygonalArea2D
|
PolygonalArea2D const reference |
required |
SetTopPlane(plane)
Set top clipping plane
Parameters:
Name | Type | Description | Default |
---|---|---|---|
plane
|
Plane3D
|
Plane3D const reference |
required |
__eq__(clippedSweptSolid)
Comparison of clippedSweptSolids without tolerance.
Be careful, this method work without tolerance!
Parameters:
Name | Type | Description | Default |
---|---|---|---|
clippedSweptSolid
|
ClippedSweptSolid3D
|
Compared clippedSweptSolid. |
required |
Returns:
Type | Description |
---|---|
object
|
True when clippedSweptSolids are equal, otherwise false. |
__init__
overload
__init__()
Initialize
__init__(area, bottom, top)
Constructor which sets swept area, bottom and top planes.
Parameters:
Name | Type | Description | Default |
---|---|---|---|
area
|
PolygonalArea2D
|
PolygonalArea3D |
required |
bottom
|
Plane3D
|
Bottom Plane3D |
required |
top
|
Plane3D
|
Top Plane3D |
required |
__init__(solid)
Copy constructor.
Parameters:
Name | Type | Description | Default |
---|---|---|---|
solid
|
ClippedSweptSolid3D
|
Clipped swept area solid which will be copied |
required |
__init__(refPoint, solid)
Copy constructor.
Parameters:
Name | Type | Description | Default |
---|---|---|---|
refPoint
|
Point3D
|
reference point |
required |
solid
|
ClippedSweptSolid3D
|
Solid which will be copied |
required |
__mul__(matrix)
Matrix transformation
Parameters:
Name | Type | Description | Default |
---|---|---|---|
matrix
|
Matrix3D
|
Transformation 3D matrix |
required |
Returns:
Type | Description |
---|---|
object
|
Transformed ClippedSweptSolid3D |
__repr__()
Convert the list to a string
Returns:
Type | Description |
---|---|
str
|
List values as string |