Closed Area2D
Class full path: NemAll_Python_Geometry.ClosedArea2D
2D closed area Representation class for 2D geometry closed (path bounded) area
Attributes
InnerList: None
property
Get the inner path list as property
:type: None
OuterCurve: None
property
Get and set the outer path as property
:type: None
Functions
AddInnerCurve(innerpath)
Add new inner curve
Parameters:
Name | Type | Description | Default |
---|---|---|---|
innerpath
|
Path2D
|
New inner curve ( Path2D ) |
required |
Returns:
Type | Description |
---|---|
bool
|
true if the operation was successful |
Clear()
Clear all the components of this Area
GetInnerCurve(index)
Get the curve of given index
Parameters:
Name | Type | Description | Default |
---|---|---|---|
index
|
int
|
Index of the inner curve |
required |
Returns:
Type | Description |
---|---|
Path2D
|
const reference to the curve ( Path2D ) |
GetInnerList()
Get the list of the inner curves
Returns:
Type | Description |
---|---|
Path2DList
|
reference to a vector that contains the inner curves ( Path2D ) |
GetOuterCurve()
Get the outer curve of this area
Returns:
Type | Description |
---|---|
Path2D
|
const reference to outer curve ( Path2D ) |
InnerCount()
Get the count of inner curves
Returns:
Type | Description |
---|---|
int
|
count of inner curves |
IsValid()
Set Check the validity
Returns:
Type | Description |
---|---|
bool
|
true if this Area is valid |
SetOuterCurve(outerpath)
Set new Outer curve ( bounds )
Parameters:
Name | Type | Description | Default |
---|---|---|---|
outerpath
|
Path2D
|
New outer curve ( Path2D ) |
required |
__eq__(closedArea)
Comparison of closedAreas without tolerance.
Be careful, this method work without tolerance!
Parameters:
Name | Type | Description | Default |
---|---|---|---|
closedArea
|
ClosedArea2D
|
Compared closedArea. |
required |
Returns:
Type | Description |
---|---|
object
|
True when closedAreas are equal, otherwise false. |
__init__
overload
__init__()
Initialize
__init__(area)
Copy constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
area
|
ClosedArea2D
|
Area which will be copied. |
required |
__repr__()
Convert the list to a string
Returns:
Type | Description |
---|---|
str
|
List values as string |