Closed Area3D
Class full path: NemAll_Python_Geometry.ClosedArea3D
3D closed area Representation class for 3D geometry area
Attributes
RefPlacement: None
property
Get and set the reference placement 3d as property
:type: None
Functions
AddInnerCurve(innerpath)
Add new inner curve
Parameters:
Name | Type | Description | Default |
---|---|---|---|
innerpath
|
Path2D
|
New inner curve ( Path2D ) |
required |
Returns:
Type | Description |
---|---|
bool
|
true if the operation was successful |
Clear()
Clear all the components of this Profile
GetInnerCurve(index)
Get the curve of given index
Parameters:
Name | Type | Description | Default |
---|---|---|---|
index
|
int
|
Index of the inner curve |
required |
Returns:
Type | Description |
---|---|
Path2D
|
const reference to the curve ( Path2D ) |
GetInnerList()
Get the list of the inner curves
Returns:
Type | Description |
---|---|
Path2DList
|
reference to a vector that contains the inner curves ( Path2D ) |
GetOuterCurve()
Get the outer curve of this profile
Returns:
Type | Description |
---|---|
Path2D
|
const reference to outer curve ( Path2D ) |
GetRefPlacement()
Get axis placement
Returns:
Type | Description |
---|---|
AxisPlacement3D
|
const reference to the reference axis placement |
InnerCount()
Get the count of inner curves
Returns:
Type | Description |
---|---|
int
|
count of inner curves |
IsValid()
Set Check the validity
Returns:
Type | Description |
---|---|
bool
|
true if this Profile is valid |
SetOuterCurve(outerpath)
Set new Outer curve ( bounds )
Parameters:
Name | Type | Description | Default |
---|---|---|---|
outerpath
|
Path2D
|
New outer curve ( Path2D ) |
required |
SetRefPlacement(placement)
Set axis placement
Parameters:
Name | Type | Description | Default |
---|---|---|---|
placement
|
AxisPlacement3D
|
Reference axis placement |
required |
__eq__(closedArea)
Comparison of closedAreas without tolerance.
Be careful, this method work without tolerance!
Parameters:
Name | Type | Description | Default |
---|---|---|---|
closedArea
|
ClosedArea3D
|
Compared closedArea. |
required |
Returns:
Type | Description |
---|---|
object
|
True when closedAreas are equal, otherwise false. |
__init__
overload
__init__()
Initialize
__init__(closedArea)
Copy constructor.
Parameters:
Name | Type | Description | Default |
---|---|---|---|
closedArea
|
ClosedArea3D
|
3D closed area which will be copied. |
required |
__repr__()
Convert the list to a string
Returns:
Type | Description |
---|---|
str
|
List values as string |