Ellipsoid3D
Class full path: NemAll_Python_Geometry.Ellipsoid3D
3D ellipsoid
Attributes
LocalPlacement: None
property
Get and set the local placement property
:type: None
XRadius: None
property
Get and set the x radius property
:type: None
YRadius: None
property
Get and set the y radius property
:type: None
ZRadius: None
property
Get and set the z radius property
:type: None
Functions
GetCenter()
Get Center of the Ellipsoid
Returns:
Type | Description |
---|---|
Point3D
|
Reference to Center. |
GetIsoLines(USegmentsCount, VSegmentsCount)
Test whether the Ellipsoid is Sphere
Parameters:
Name | Type | Description | Default |
---|---|---|---|
USegmentsCount
|
int
|
count of circles |
required |
VSegmentsCount
|
int
|
count of circles |
required |
Returns:
Type | Description |
---|---|
Arc3DList
|
vector of circles |
GetLocalPlacement()
Get Local Placement
Returns:
Type | Description |
---|---|
AxisPlacement3D
|
Reference to Local Placement. |
GetSilhouetteContour(viewMatrix, bPerspective)
Get silhouette circle
Parameters:
Name | Type | Description | Default |
---|---|---|---|
viewMatrix
|
Matrix3D
|
view matrix |
required |
bPerspective
|
bool
|
central perspective true/false |
required |
Returns:
Type | Description |
---|---|
Arc3D
|
silhouette |
GetXAxis()
Get X-Axis of the placement of the Ellipsoid
Returns:
Type | Description |
---|---|
Vector3D
|
Reference to X-Axis. |
GetXRadius()
Get X Radius of the Ellipsoid
Returns:
Type | Description |
---|---|
float
|
Reference to X Radius. |
GetYAxis()
Get Y-Axis of the placement of the Ellipsoid
Returns:
Type | Description |
---|---|
Vector3D
|
Reference to X-Axis. |
GetYRadius()
Get Y Radius of the Ellipsoid
Returns:
Type | Description |
---|---|
float
|
Reference to Y Radius. |
GetZAxis()
Get Z - axis of the placement of the Ellipsoid
Returns:
Type | Description |
---|---|
Vector3D
|
Reference to Z-axis. |
GetZRadius()
Get Z Radius of the Ellipsoid
Returns:
Type | Description |
---|---|
float
|
Reference to Z Radius. |
IsSphere()
Test whether the Ellipsoid is Sphere
Returns:
Type | Description |
---|---|
bool
|
true/false |
IsValid()
Validity check of the Ellipsoid
Returns:
Type | Description |
---|---|
bool
|
true/false |
SetCenter(center)
Set center
Parameters:
Name | Type | Description | Default |
---|---|---|---|
center
|
Point3D
|
New center. |
required |
SetLocalPlacement
overload
SetLocalPlacement(placement)
Set Local Placement.
Parameters:
Name | Type | Description | Default |
---|---|---|---|
placement
|
AxisPlacement3D
|
Local Placement. |
required |
SetLocalPlacement(center, xAxis, zAxis)
Set Local Placement.
Parameters:
Name | Type | Description | Default |
---|---|---|---|
center
|
Point3D
|
Center point of the placement |
required |
xAxis
|
Vector3D
|
X-axis of the placement |
required |
zAxis
|
Vector3D
|
Z-axis of the placement |
required |
SetXRadius(rad)
Set X Radius of the Ellipsoid
Parameters:
Name | Type | Description | Default |
---|---|---|---|
rad
|
float
|
New radius. |
required |
Returns:
Type | Description |
---|---|
Reference to X Radius. |
SetYRadius(rad)
Set Y Radius of the Ellipsoid
Parameters:
Name | Type | Description | Default |
---|---|---|---|
rad
|
float
|
New radius |
required |
SetZRadius(rad)
Set Z Radius of the Ellipsoid
Parameters:
Name | Type | Description | Default |
---|---|---|---|
rad
|
float
|
New radius |
required |
__eq__(ellipsoid)
Comparison of ellipsoids without tolerance.
Be careful, this method work without tolerance!
Parameters:
Name | Type | Description | Default |
---|---|---|---|
ellipsoid
|
Ellipsoid3D
|
Compared ellipsoid. |
required |
Returns:
Type | Description |
---|---|
object
|
True when ellipsoids are equal, otherwise false. |
__init__
overload
__init__()
Initialize
__init__(ellipsoid)
Copy constructor.
Parameters:
Name | Type | Description | Default |
---|---|---|---|
ellipsoid
|
Ellipsoid3D
|
Ellipsoid which will be copied. |
required |
__init__(refPlacement, radiusX, radiusY, radiusZ)
Constructor.
Parameters:
Name | Type | Description | Default |
---|---|---|---|
refPlacement
|
AxisPlacement3D
|
Local Placement of the ellipsoid. |
required |
radiusX
|
float
|
X radius of the Ellipsoid. |
required |
radiusY
|
float
|
Y radius of the Ellipsoid. |
required |
radiusZ
|
float
|
Z radius of the Ellipsoid. |
required |
__init__(radiusX, radiusY, radiusZ)
Constructor.
Parameters:
Name | Type | Description | Default |
---|---|---|---|
radiusX
|
float
|
X radius of the Ellipsoid. |
required |
radiusY
|
float
|
Y radius of the Ellipsoid. |
required |
radiusZ
|
float
|
Z radius of the Ellipsoid. |
required |
__repr__()
Convert the list to a string
Returns:
Type | Description |
---|---|
str
|
List values as string |