Extruded Area Solid3D
Class full path: NemAll_Python_Geometry.ExtrudedAreaSolid3D
Solid created by extrusion of area by given direction vector
Attributes
Direction: None
property
Get and set the direction as property
:type: None
ExtrudedArea: None
property
Get and set the extruded area as property
:type: None
RefPoint: None
property
Get and set the reference point as property
:type: None
Functions
GetDirection()
Get direction for extrusion
Returns:
Type | Description |
---|---|
Vector3D
|
Vector3D const reference |
GetExtrudedArea()
Get extruded area
Returns:
Type | Description |
---|---|
PolygonalArea3D
|
PolygonalArea3D const reference |
GetRefPoint()
Get the reference point
Returns:
Type | Description |
---|---|
Point3D
|
Reference point |
IsValid()
Check if the Solid is valid
Returns:
Type | Description |
---|---|
bool
|
True if it is a valid solid |
SetDirection(dir)
Set direction for extrusion
Parameters:
Name | Type | Description | Default |
---|---|---|---|
dir
|
Vector3D
|
Vector3D const reference |
required |
SetExtrudedArea(area)
Set extruded area
Parameters:
Name | Type | Description | Default |
---|---|---|---|
area
|
PolygonalArea3D
|
PolygonalArea3D const reference |
required |
SetRefPoint(refPoint)
Set reference point
Parameters:
Name | Type | Description | Default |
---|---|---|---|
refPoint
|
Point3D
|
New reference point |
required |
__eq__(extrudedAreaSolid)
Comparison of extrudedAreaSolids without tolerance.
Be careful, this method work without tolerance!
Parameters:
Name | Type | Description | Default |
---|---|---|---|
extrudedAreaSolid
|
ExtrudedAreaSolid3D
|
Compared extrudedAreaSolid. |
required |
Returns:
Type | Description |
---|---|
object
|
True when extrudedAreaSolids are equal, otherwise false. |
__init__
overload
__init__()
Initialize
__init__(solid)
Copy constructor.
Parameters:
Name | Type | Description | Default |
---|---|---|---|
solid
|
ExtrudedAreaSolid3D
|
Extruded area solid which will be copied |
required |
__init__(solid, refPoint)
Copy constructor.
Parameters:
Name | Type | Description | Default |
---|---|---|---|
solid
|
Point3D
|
Solid which will be copied |
required |
refPoint
|
ExtrudedAreaSolid3D
|
reference point |
required |
__mul__(matrix)
Matrix transformation
Parameters:
Name | Type | Description | Default |
---|---|---|---|
matrix
|
Matrix3D
|
Transformation 3D matrix |
required |
__repr__()
Convert the list to a string
Returns:
Type | Description |
---|---|
str
|
List values as string |