Fillet Calculus2D
Class full path: NemAll_Python_Geometry.FilletCalculus2D
Class for fillet calculation between two 2D objects
Functions
ClickedOnObject
overload
ClickedOnObject(line, clickedPoint, searchRadius)
staticmethod
Check if click point is a point located on given line
Parameters:
Name | Type | Description | Default |
---|---|---|---|
line
|
Line2D
|
Line2D which will be checked |
required |
clickedPoint
|
Point2D
|
clicked point |
required |
searchRadius
|
float
|
search radius |
required |
Returns:
Type | Description |
---|---|
bool
|
true if point is on the line |
ClickedOnObject(arc, clickedPoint, searchRadius)
staticmethod
Check if click point is a point located on given arc
Parameters:
Name | Type | Description | Default |
---|---|---|---|
arc
|
Arc2D
|
Arc2D which will be checked |
required |
clickedPoint
|
Point2D
|
clicked point |
required |
searchRadius
|
float
|
search radius |
required |
Returns:
Type | Description |
---|---|
bool
|
true if point is on the arc |
GetArcHelpConstructions()
Get all arc help constructions
Returns:
Type | Description |
---|---|
Arc2DList
|
all arc help constructions |
GetFilletType
overload
GetFilletType(line1, line2)
staticmethod
Get fillet type for two lines
Parameters:
Name | Type | Description | Default |
---|---|---|---|
line1
|
Line2D
|
first line |
required |
line2
|
Line2D
|
second line |
required |
Returns:
Type | Description |
---|---|
eFilletType
|
eFilletType |
GetFilletType(line, arc)
staticmethod
Get fillet type for line and arc
Parameters:
Name | Type | Description | Default |
---|---|---|---|
line
|
Line2D
|
line |
required |
arc
|
Arc2D
|
arc |
required |
Returns:
Type | Description |
---|---|
eFilletType
|
eFilletType |
GetFilletType(arc1, arc2)
staticmethod
Get fillet type for two arcs
Parameters:
Name | Type | Description | Default |
---|---|---|---|
arc1
|
Arc2D
|
first arc |
required |
arc2
|
Arc2D
|
second arc |
required |
Returns:
Type | Description |
---|---|
eFilletType
|
eFilletType |
GetFilletType(geometry1, geometry2)
staticmethod
Get fillet type for two geometry objects
Parameters:
Name | Type | Description | Default |
---|---|---|---|
geometry1
|
object
|
first geometry element |
required |
geometry2
|
object
|
second geometry element |
required |
Returns:
Type | Description |
---|---|
eFilletType
|
eFilletType |
GetFillets()
Get all possible fillets
Returns:
Type | Description |
---|---|
Arc2DList
|
possible fillets |
GetLineHelpConstructions()
Get all line help constructions
Returns:
Type | Description |
---|---|
object
|
all line help constructions |
GetNearest(point)
Get the nearest fillet to the point
Parameters:
Name | Type | Description | Default |
---|---|---|---|
point
|
Point2D
|
Point2D |
required |
Returns:
Type | Description |
---|---|
Arc2D
|
nearest arc to the point |
SplitPolylineBySegment(polyline, segment)
staticmethod
Split polyline by given segment
Parameters:
Name | Type | Description | Default |
---|---|---|---|
polyline
|
Polyline2D
|
polyline which will be split by given segment |
required |
segment
|
int
|
segment where polyline will be split |
required |
Returns:
Type | Description |
---|---|
tuple
|
first part of polyline, |
tuple
|
second part of polyline |
TrimByHelpConstruction
overload
TrimByHelpConstruction(line, hcLine, intersections)
staticmethod
Trim line by given help construction
Parameters:
Name | Type | Description | Default |
---|---|---|---|
line
|
Line2D
|
line which will be trimmed |
required |
hcLine
|
Line2D
|
line help construction |
required |
intersections
|
Point3DList
|
intersection points |
required |
Returns:
Type | Description |
---|---|
Line2D
|
line which will be trimmed |
TrimByHelpConstruction(polyline, segment, hcLine, intersections)
staticmethod
Trim polyline by given help construction
Parameters:
Name | Type | Description | Default |
---|---|---|---|
polyline
|
Polyline2D
|
polyline which will be trimmed |
required |
segment
|
Line2D
|
selected segment |
required |
hcLine
|
Line2D
|
line help construction |
required |
intersections
|
Point3DList
|
intersection points |
required |
Returns:
Type | Description |
---|---|
Polyline2D
|
polyline which will be trimmed |
TrimByHelpConstruction(arc, hcArc, intersections)
staticmethod
Trim arc by given help construction
Parameters:
Name | Type | Description | Default |
---|---|---|---|
arc
|
Arc2D
|
arc which will be trimmed |
required |
hcArc
|
Arc2D
|
arc help construction |
required |
intersections
|
Point3DList
|
intersection points |
required |
Returns:
Type | Description |
---|---|
Arc2D
|
arc which will be trimmed |
UpdateBySelectedHelpConstruction
overload
UpdateBySelectedHelpConstruction(polyline, segment, trimHelpConstruction, intersection)
staticmethod
Update polyline by selected help construction
Parameters:
Name | Type | Description | Default |
---|---|---|---|
polyline
|
Polyline2D
|
polyline which will be updated |
required |
segment
|
Line2D
|
selected segment |
required |
trimHelpConstruction
|
object
|
help construction data |
required |
intersection
|
Point2D
|
intersection |
required |
Returns:
Type | Description |
---|---|
Polyline2D
|
polyline which will be updated |
UpdateBySelectedHelpConstruction(line, trimHelpConstruction, intersection)
staticmethod
Update line by selected help construction
Parameters:
Name | Type | Description | Default |
---|---|---|---|
line
|
Line2D
|
line which will be updated by help construction |
required |
trimHelpConstruction
|
object
|
help construction data |
required |
intersection
|
Point2D
|
intersection |
required |
Returns:
Type | Description |
---|---|
Line2D
|
line which will be updated by help construction |
UpdateGeometry
overload
UpdateGeometry(geoArc, fillet, selectedGeometry)
staticmethod
Update arc geometry
Parameters:
Name | Type | Description | Default |
---|---|---|---|
geoArc
|
Arc2D
|
arc which will be updated |
required |
fillet
|
Arc2D
|
Arc2D |
required |
selectedGeometry
|
object
|
selected geometry |
required |
Returns:
Type | Description |
---|---|
Arc2D
|
arc which will be updated |
UpdateGeometry(geoPolyline, fillet, selectedGeometry1, selectedGeometry2)
staticmethod
Update polyline geometry
Parameters:
Name | Type | Description | Default |
---|---|---|---|
geoPolyline
|
Polyline2D
|
polyline which will be updated |
required |
fillet
|
Arc2D
|
Arc2D |
required |
selectedGeometry1
|
object
|
First selected segment |
required |
selectedGeometry2
|
object
|
Second selected segment |
required |
Returns:
Type | Description |
---|---|
Polyline2DList
|
Result polylines |
UpdateGeometry(geoPolyline, fillet, selectedGeometry)
staticmethod
Update polyline geometry
Parameters:
Name | Type | Description | Default |
---|---|---|---|
geoPolyline
|
Polyline2D
|
polyline which will be updated |
required |
fillet
|
Arc2D
|
Arc2D |
required |
selectedGeometry
|
object
|
selected geometry |
required |
Returns:
Type | Description |
---|---|
Polyline2D
|
polyline which will be updated |
UpdateGeometry(geoPolyline, fillet, selectedGeometry1, selectedGeometry2, segmentCount)
staticmethod
Update polyline geometry
Parameters:
Name | Type | Description | Default |
---|---|---|---|
geoPolyline
|
Polyline2D
|
polyline which will be updated |
required |
fillet
|
Arc2D
|
Arc2D |
required |
selectedGeometry1
|
object
|
the first selected geometry |
required |
selectedGeometry2
|
object
|
the second selected geometry |
required |
segmentCount
|
int
|
required count of segments of the polygonized fillet |
required |
Returns:
Type | Description |
---|---|
Polyline2D
|
polyline which will be updated |
UpdateGeometry(geoPolygon, fillet, segment1, segment2, segmentCount)
staticmethod
Update polyline geometry
Parameters:
Name | Type | Description | Default |
---|---|---|---|
geoPolygon
|
Polygon2D
|
polygon which will be updated |
required |
fillet
|
Arc2D
|
Arc2D |
required |
segment1
|
Line2D
|
first selected geometry |
required |
segment2
|
Line2D
|
second selected geometry |
required |
segmentCount
|
int
|
required count of segments of the polygonized fillet |
required |
Returns:
Type | Description |
---|---|
Polygon2D
|
geoPolygon which will be updated |
UpdateGeometry(geoSpline, fillet)
staticmethod
Update spline geometry
Parameters:
Name | Type | Description | Default |
---|---|---|---|
geoSpline
|
Spline2D
|
spline which will be updated |
required |
fillet
|
Arc2D
|
Arc2D |
required |
Returns:
Type | Description |
---|---|
Spline2D
|
spline which will be updated |
UpdateGeometry(geoLine, fillet, selectedGeometry)
staticmethod
Update lien geometry
Parameters:
Name | Type | Description | Default |
---|---|---|---|
geoLine
|
Line2D
|
line which will be updated |
required |
fillet
|
Arc2D
|
Arc2D |
required |
selectedGeometry
|
object
|
selected geometry |
required |
Returns:
Type | Description |
---|---|
Line2D
|
line which will be updated |
__init__
overload
__init__(line1, line2, r)
constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
line1
|
Line2D
|
Line2D |
required |
line2
|
Line2D
|
Line2D |
required |
r
|
float
|
radius |
required |
__init__(line, arc, r)
constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
line
|
Line2D
|
Line2D |
required |
arc
|
Arc2D
|
Arc2D |
required |
r
|
float
|
radius |
required |
__init__(arc1, arc2, r)
constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
arc1
|
Arc2D
|
Arc2D |
required |
arc2
|
Arc2D
|
Arc2D |
required |
r
|
float
|
radius |
required |
__init__(arc, point)
constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
arc
|
Arc2D
|
Arc2D |
required |
point
|
Point2D
|
Point2D |
required |
__init__(line, point)
constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
line
|
Line2D
|
Line2D |
required |
point
|
Point2D
|
Point2D |
required |
__init__(geoObj1, geoObj2, r)
constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
geoObj1
|
object
|
IGeometry object |
required |
geoObj2
|
object
|
IGeometry object |
required |
r
|
float
|
radius |
required |