Fillet Calculus3D
Class full path: NemAll_Python_Geometry.FilletCalculus3D
Class for 3D fillet calculation
Functions
Calculate
overload
Calculate(line1, line2, radius)
staticmethod
Calculate fillet between two coplanar 3d lines
Parameters:
Name | Type | Description | Default |
---|---|---|---|
line1
|
Line3D
|
first Line3D |
required |
line2
|
Line3D
|
second Line3D |
required |
radius
|
float
|
radius of fillet |
required |
Returns:
Type | Description |
---|---|
tuple
|
error code, |
tuple
|
resulting first Line3D |
tuple
|
resulting second Line3D |
tuple
|
calculated fillet |
Calculate(line1, line2)
staticmethod
Calculate fillet between two parallel non collinear 3d lines. The end point of the first line must lie on the same plane as start point of the second line and plane is perpendicular to both lines.
Parameters:
Name | Type | Description | Default |
---|---|---|---|
line1
|
Line3D
|
first Line3D |
required |
line2
|
Line3D
|
second Line3D |
required |
Returns:
Type | Description |
---|---|
tuple
|
error code, |
tuple
|
calculated fillet |
Calculate(line1, endPoint, polyline, startLineIndex, endLineIndex, radius)
staticmethod
Calculate fillet between line1 and line2. Line2 is created as line between end point of line1 (by parameter endPoint) and point from polyline (limited with startPointIndex and endPointIndex)
Parameters:
Name | Type | Description | Default |
---|---|---|---|
line1
|
Line3D
|
Line 1 for fillet |
required |
endPoint
|
eLinePointIdentification
|
Sign for line2 (from where point of line1 should be start line2) |
required |
polyline
|
Polyline3D
|
Polyline (buffer of end points for line2) |
required |
startLineIndex
|
int
|
Start point index for polyline |
required |
endLineIndex
|
int
|
End point index for polyline |
required |
radius
|
float
|
radius of fillet |
required |
Returns:
Type | Description |
---|---|
tuple
|
error code, |
tuple
|
Line 1 from fillet calculation, |
tuple
|
Line 2 from fillet calculation, |
tuple
|
Calculated fillet |
Calculate(polyhedron, edges, radius, propagation)
staticmethod
Calculate fillet on selected edges of given Polyhedron3D
Parameters:
Name | Type | Description | Default |
---|---|---|---|
polyhedron
|
Polyhedron3D
|
polyhedron to fillet |
required |
edges
|
VecSizeTList
|
edges to fillet |
required |
radius
|
float
|
fillet sphere radius |
required |
propagation
|
bool
|
flag for propagation of neighboring edges |
required |
Returns:
Type | Description |
---|---|
tuple
|
error code, |
tuple
|
resulting BRep3D |
Calculate(brep, radius)
staticmethod
Calculate fillet on all edges of given BRep3D
Parameters:
Name | Type | Description | Default |
---|---|---|---|
brep
|
BRep3D
|
brep to fillet |
required |
radius
|
float
|
fillet sphere radius |
required |
Returns:
Type | Description |
---|---|
tuple
|
error code, |
tuple
|
resulting brep |
Calculate(brep, edges, radius, propagation)
staticmethod
Calculate fillet on selected edges of given BRep3D
Parameters:
Name | Type | Description | Default |
---|---|---|---|
brep
|
BRep3D
|
brep to fillet |
required |
edges
|
VecSizeTList
|
edges to fillet |
required |
radius
|
float
|
fillet sphere radius |
required |
propagation
|
bool
|
flag for propagation of neighboring edges |
required |
Returns:
Type | Description |
---|---|
tuple
|
error code, |
tuple
|
resulting brep |