Geometry Edge
Class full path: NemAll_Python_Geometry.GeometryEdge
Geometry edge Identification of any edge via point indices, not via point coordinates.
Attributes
EndIndex: None
property
Get and set the end index property
:type: None
StartIndex: None
property
Get and set the start index property
:type: None
Functions
GetEndIndex()
Get end index
Returns:
Type | Description |
---|---|
int
|
End index. |
GetStartIndex()
Get start index
Returns:
Type | Description |
---|---|
int
|
Start index. |
Set(edge)
Initialize edge from old Allplan structure
Parameters:
Name | Type | Description | Default |
---|---|---|---|
edge
|
Kanten_t
|
Edge which will be copied. |
required |
SetEndIndex(index)
Set end index
Index is not checked, you set anything.
Parameters:
Name | Type | Description | Default |
---|---|---|---|
index
|
int
|
End index. |
required |
SetStartIndex(index)
Set start index
Index is not checked, you set anything.
Parameters:
Name | Type | Description | Default |
---|---|---|---|
index
|
int
|
Start index. |
required |
__eq__(edge)
Comparison of edges without tolerance.
Be careful, this method work without tolerance!
Parameters:
Name | Type | Description | Default |
---|---|---|---|
edge
|
GeometryEdge
|
Compared edge. |
required |
Returns:
Type | Description |
---|---|
object
|
True when edges are equal, otherwise false. |
__init__
overload
__init__()
Initialize
__init__(startIndex, endIndex)
Constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
startIndex
|
int
|
Start index of vertex. |
required |
endIndex
|
int
|
End index of vertex. |
required |
__init__(edge)
Copy constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
edge
|
GeometryEdge
|
Edge which will be copied. |
required |
__init__(edge)
Copy constructor from old Allplan structure
Parameters:
Name | Type | Description | Default |
---|---|---|---|
edge
|
Kanten_t
|
Edge which will be copied. |
required |
__repr__()
Convert the list to a string
Returns:
Type | Description |
---|---|
str
|
List values as string |