Healing Settings
Class full path: NemAll_Python_Geometry.HealingSettings
Class holding Healing settings for elements.
Functions
GetPolygonHealingSettings()
Get Healing settings for polygon
Returns:
Type | Description |
---|---|
ePolygonHealingSettings
|
const Reference to Polygon healing settings |
GetPolyhedronHealingSettings()
Get Healing settings for polyhedron
Returns:
Type | Description |
---|---|
ePolyhedronHealingSettings
|
const Reference to Polyhedron healing settings |
IsPolygonNoModify()
Check whether the type of the settings for polygon is PHSET_NOMODIFY
Returns:
Type | Description |
---|---|
bool
|
true/false. |
IsPolygonNormalize()
Check whether the type of the settings for polygon is PHSET_NOMODIFY
Returns:
Type | Description |
---|---|
bool
|
true/false. |
IsPolyhedronNoModify()
Check whether the type of the settings for polyhedron is HSET_NOMODIFY
Returns:
Type | Description |
---|---|
bool
|
true/false. |
IsPolyhedronTilt()
Check whether the type of the settings for polyhedron is HSET_TILT
Returns:
Type | Description |
---|---|
bool
|
true/false. |
IsPolyhedronTriangulate()
Check whether the type of the settings for polyhedron is HSET_TRIANGULATE
Returns:
Type | Description |
---|---|
bool
|
true/false. |
IsPolyhedronUnknown()
Check whether the type of the settings for polyhedron is HSET_TRIANGULATE
Returns:
Type | Description |
---|---|
bool
|
true/false. |
IsWeldVerticesEnabled()
Check if vertices welding is enabled
Returns:
Type | Description |
---|---|
bool
|
true/false. |
SetPolygonHealingSettings(pgonSet)
Set healing settings for polygon.
Parameters:
Name | Type | Description | Default |
---|---|---|---|
pgonSet
|
ePolygonHealingSettings
|
new value. |
required |
SetPolyhedronHealingSettings(phedSet)
Set healing settings for polyhedron.
Parameters:
Name | Type | Description | Default |
---|---|---|---|
phedSet
|
ePolyhedronHealingSettings
|
new value. |
required |
SetWeldVertices(enableWeld)
Set vertices welding
Parameters:
Name | Type | Description | Default |
---|---|---|---|
enableWeld
|
bool
|
Enable vertices welding |
required |
__init__
overload
__init__(oPhedType=ePolyhedronHealingSettings.HSET_TRIANGULATE, oPgonType=ePolygonHealingSettings.PHSET_NOMODIFY, weldVertices=False)
Default constructor.
Types can be found in GeometryEnums.h
Parameters:
Name | Type | Description | Default |
---|---|---|---|
oPhedType
|
ePolyhedronHealingSettings
|
Settings for the polyhedron |
HSET_TRIANGULATE
|
oPgonType
|
ePolygonHealingSettings
|
Settings for the polygon |
PHSET_NOMODIFY
|
weldVertices
|
bool
|
Vertices welding option, if true weld vertices |
False
|
__init__(hSet)
Copy constructor.
Parameters:
Name | Type | Description | Default |
---|---|---|---|
hSet
|
HealingSettings
|
ApproximationSettings which will be copied. |
required |