Hidden Calculation Parameters
Class full path: NemAll_Python_Geometry.HiddenCalculationParameters
Parameters of hidden calculation.
Attributes
AdjacentEdgesMaxAngle: Angle
property
writable
Adjacent edges max angle.
Maximal angle in which adjacent edges will be joined.
GetHiddenLines: bool
property
writable
Determines if get also hidden lines.
If false only visible lines are produced during hidden calculation.
ObserverMatrix: Matrix3D
property
writable
Observer matrix;
Functions
SetObserverMatrix(eyePoint, viewPoint)
Calculates observer matrix from 2 points.
Parameters:
Name | Type | Description | Default |
---|---|---|---|
eyePoint
|
Point3D
|
Eye point. |
required |
viewPoint
|
Point3D
|
View point. |
required |
__init__
overload
__init__()
Initialize
__init__(param)
Copy constructor.
Parameters:
Name | Type | Description | Default |
---|---|---|---|
param
|
HiddenCalculationParameters
|
|
required |