Hidden Calculus
Class full path: NemAll_Python_Geometry.HiddenCalculus
Hidden calculation service implementation, user part.
This template over HiddenCalculusImpl implements type safe tag storing for hidden calculation. It holds the vector of all used tags and convert them to void* needed in HiddenCalculusImpl.
Functions
AddElement(elementGeometry_object, elenentMaterial, elementTag)
Add element geometry to hidden world.
Parameters:
Name | Type | Description | Default |
---|---|---|---|
elementGeometry_object
|
object
|
Element geometry. |
required |
elenentMaterial
|
HiddenMaterial
|
Element material. |
required |
elementTag
|
int
|
Tag transferred over hidden calculation from element to line. |
required |
Calculate()
Runs hidden calculation.
hrow Exception in case of internal error.
Configure(parameters)
Sets parameters of calculation.
Parameters:
Name | Type | Description | Default |
---|---|---|---|
parameters
|
HiddenCalculationParameters
|
New parameters. |
required |
GetLinesCount()
Gets total count of lines calculated.
hrow Exception in case of internal error and if no
\c Calculate() was called.
Returns:
Type | Description |
---|---|
int
|
size_t Lines count. |
GetResultLine(lineIndex)
GetResultLine
hrow Exception if index out of range.
Parameters:
Name | Type | Description | Default |
---|---|---|---|
lineIndex
|
int
|
Index of line. |
required |
Returns:
Type | Description |
---|---|
Line3D
|
tuple(Line calculated by hidden itself, |
eHiddenCalculationResult
|
Result of hidden for line. Hidden visible) |
GetResultLineMaterial(lineIndex)
Gets hidden material of element line is from.
hrow Exception if\c lineIndex out of range.
Parameters:
Name | Type | Description | Default |
---|---|---|---|
lineIndex
|
int
|
Index of line. |
required |
Returns:
Type | Description |
---|---|
HiddenMaterial
|
HiddenMaterial Material. |
GetResultLineTag(lineIndex)
Gets (reference to) tag hooked to element line is from.
Parameters:
Name | Type | Description | Default |
---|---|---|---|
lineIndex
|
int
|
Index of line. |
required |
Returns:
Type | Description |
---|---|
int
|
const TagType Reference to tag object. |
__init__()
Initialize