Intersect Ray Polyhedron Flag
Class full path: NemAll_Python_Geometry.IntersectRayPolyhedronFlag
Bases: IntEnum
Flag for determining the best result of ray-polyhedron intersection
allow only intersections with lambda >= 0
prefer the smallest one
eNegativeIfNoPositive : allow negative intersections, but only if not positive intersection can be found prefer intersections with lambda close to 0 (i.e., prefer -1 over -2) eNegativePreferred : search for the intersection with the smallest lambda prefer negative over positive, prefer -2 over -1 (this is a simple linear comparison) eSmallestLmabda : search for the intersection with the smallest lambda
Attributes
eNegativeIfNoPositive = 1
class-attribute
instance-attribute
eNegativePreferred = 2
class-attribute
instance-attribute
ePositiveOnly = 0
class-attribute
instance-attribute
eSmallestLmabda = 3
class-attribute
instance-attribute
Functions
__getitem__(key)
get the item for a key
Parameters:
Name | Type | Description | Default |
---|---|---|---|
key
|
str | int | float
|
value key |
required |
Returns:
Type | Description |
---|---|
IntersectRayPolyhedronFlag
|
value for the key |