Intersection Ray Polyhedron
Class full path: NemAll_Python_Geometry.IntersectionRayPolyhedron
Intersection result of the ray - Polyhedron3D intersection
Attributes
FaceIdx: int
property
writable
face index of the face of the best intersection (if found, not unique) beginning from 0
FaceNv: Vector3D
property
writable
normal vector of best-intersected face (if found, not unique)
IntersectionPoint: Point3D
property
writable
intersection point (if found)
Lambda: float
property
writable
ray parameter of returned intersection (if found)
RetCode: int
property
writable
0: no inters.,
1: pos. inters. found,
-1: only neg. inters. found
Functions
__init__(element)
Copy constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
element
|
IntersectionRayPolyhedron
|
Element to copy |
required |
__repr__()
Convert to string