Min Max3D
Class full path: NemAll_Python_Geometry.MinMax3D
Representation class for 3D MinMax box.
Attributes
Max: Point3D
property
writable
Get maximum point
Min: Point3D
property
writable
Get minimum point
SizeX: float
property
Get the size of the box in the X direction
SizeY: float
property
Get the size of the box in the Y direction
SizeZ: float
property
Get the size of the box in the Y direction
Functions
Deflate
overload
Deflate(size)
Deflate in x,y,z axis concurrently.
Parameters:
Name | Type | Description | Default |
---|---|---|---|
size
|
float
|
|
required |
Deflate(x, y, z)
Deflate in x, y and z axis.
Parameters:
Name | Type | Description | Default |
---|---|---|---|
x
|
float
|
|
required |
y
|
float
|
|
required |
z
|
float
|
|
required |
Get()
Get minimum and maximum point
Returns:
Type | Description |
---|---|
Point3D
|
tuple(minimum point, |
Point3D
|
maximum point) |
GetCenter()
Get box center point
Returns:
Type | Description |
---|---|
Point3D
|
center point |
GetMax()
Get maximum point
Returns:
Type | Description |
---|---|
Point3D
|
maximum point |
GetMin()
Get minimum point
Returns:
Type | Description |
---|---|
Point3D
|
minimum point |
GetSizeX()
Get the size of the box in the X direction
Returns:
Type | Description |
---|---|
float
|
delta X value |
GetSizeY()
Get the size of the box in the Y direction
Returns:
Type | Description |
---|---|
float
|
delta Y value |
GetSizeZ()
Get the size of the box in the Y direction
Returns:
Type | Description |
---|---|
float
|
delta Y value |
Inflate
overload
Inflate(x, y, z)
ame Inflate and deflate minmax box
Inflate in x, y and z axis.
Parameters:
Name | Type | Description | Default |
---|---|---|---|
x
|
float
|
|
required |
y
|
float
|
|
required |
z
|
float
|
|
required |
Inflate(size)
Inflate in x,y,z axis concurrently.
Parameters:
Name | Type | Description | Default |
---|---|---|---|
size
|
float
|
|
required |
IsContaining(box)
Is box inside this box
Parameters:
Name | Type | Description | Default |
---|---|---|---|
box
|
MinMax3D
|
Potentially contained box |
required |
Returns:
Type | Description |
---|---|
bool
|
true, if is inside, otherwise false |
IsValid()
Test if box is valid
Returns:
Type | Description |
---|---|
bool
|
true, if box valid, otherwise false |
Overlaps(box)
Does box overlap this box
Parameters:
Name | Type | Description | Default |
---|---|---|---|
box
|
MinMax3D
|
Box |
required |
Returns:
Type | Description |
---|---|
bool
|
true, if boxes overlap, otherwise false |
Reset()
Set min point to [DBL_MAX,DBL_MAX,DBL_MAX] and max point to [-DBL_MAX,-DBL_MAX,-DBL_MAX]
Set(min, max)
Set minimum and maximum point
Parameters:
Name | Type | Description | Default |
---|---|---|---|
min
|
Point3D
|
minimum point |
required |
max
|
Point3D
|
maximum point |
required |
SetMax(max)
Set maximum point
Parameters:
Name | Type | Description | Default |
---|---|---|---|
max
|
Point3D
|
maximum point |
required |
SetMin(min)
Set minimum point
Parameters:
Name | Type | Description | Default |
---|---|---|---|
min
|
Point3D
|
minimum point |
required |
__add__(minmax)
Expand MinMax3D box.
Expands the MinMax3D box by the box given in parameter minmax
Parameters:
Name | Type | Description | Default |
---|---|---|---|
minmax
|
MinMax3D
|
MinMax3D to be added |
required |
Returns:
Type | Description |
---|---|
MinMax3D
|
minmax box. |
__eq__(minmax)
Comparison of minmax objects without tolerance.
Be careful, this method work without tolerance!
Parameters:
Name | Type | Description | Default |
---|---|---|---|
minmax
|
MinMax3D
|
Compared minmax. |
required |
Returns:
Type | Description |
---|---|
object
|
True when minmax objects are equal, otherwise false. |
__iadd__
overload
__iadd__(minmax)
Expand MinMax3D box.
Expands the MinMax3D box by the box given in parameter minmax
Parameters:
Name | Type | Description | Default |
---|---|---|---|
minmax
|
MinMax3D
|
MinMax3D to be added |
required |
Returns:
Type | Description |
---|---|
MinMax3D
|
minmax box. |
__iadd__(point)
Expand MinMax3D box.
Expands the MinMax3D box by the Point3D given in parameter point
Parameters:
Name | Type | Description | Default |
---|---|---|---|
point
|
Point3D
|
Point3D to be added |
required |
Returns:
Type | Description |
---|---|
MinMax3D
|
minmax box. |
__init__
overload
__init__()
Initialize
__init__(min, max)
Set constructor
Initialize MinMax box with given MIN and MAX points.
Parameters:
Name | Type | Description | Default |
---|---|---|---|
min
|
Point3D
|
minimum point |
required |
max
|
Point3D
|
maximum point |
required |
__init__(point)
Set constructor
Initialize MinMax box with given point.
Parameters:
Name | Type | Description | Default |
---|---|---|---|
point
|
Point3D
|
point |
required |
__init__(minmax)
Copy constructor.
Parameters:
Name | Type | Description | Default |
---|---|---|---|
minmax
|
MinMax3D
|
MinMax3D to be copied |
required |
__repr__()
Convert to string