Offset3D Plane
Class full path: NemAll_Python_Geometry.Offset3DPlane
Bases: IntEnum
Definition of plane on which offset of 3D elements will be calculated
Attributes
eNoPlane = 0
class-attribute
instance-attribute
eXY = 1
class-attribute
instance-attribute
eXZ = 2
class-attribute
instance-attribute
eYZ = 3
class-attribute
instance-attribute
Functions
__getitem__(key)
get the item for a key
Parameters:
Name | Type | Description | Default |
---|---|---|---|
key
|
str | int | float
|
value key |
required |
Returns:
Type | Description |
---|---|
Offset3DPlane
|
value for the key |