Oriented Edge
Class full path: NemAll_Python_Geometry.OrientedEdge
Oriented edge Identification of any edge via edge handle and orientation (positive, negative).
Attributes
EdgeHandle: None
property
Get and set the edge handle property
:type: None
Positive: None
property
Get and set the positive orientation property
:type: None
Functions
GetEdgeHandle()
Get handle to the edge
Returns:
Type | Description |
---|---|
int
|
Edge handle. |
HasPositiveOrientation()
Get the flag of positive orientation.
Returns:
Type | Description |
---|---|
bool
|
True when edge have positive orientation, otherwise false. |
Set
overload
Set(orientedEdge)
Initialize edge from old Allplan structure
Parameters:
Name | Type | Description | Default |
---|---|---|---|
orientedEdge
|
OrientedEdge
|
Edge which will be copied. |
required |
Set(edgeHandle, positiveOrientation)
Set edge handle and orientation
Handle is not checked, you set anything.
Parameters:
Name | Type | Description | Default |
---|---|---|---|
edgeHandle
|
int
|
Handle to the edge which will be set. |
required |
positiveOrientation
|
bool
|
Set true when orientation is positive, otherwise false. |
required |
SetEdgeHandle(edgeHandle)
Set handle to the edge
edgeHandle is not checked, you set anything.
Parameters:
Name | Type | Description | Default |
---|---|---|---|
edgeHandle
|
int
|
Handle to the edge which will be set. |
required |
SetOrientation(positiveOrientation)
Set orientation
Parameters:
Name | Type | Description | Default |
---|---|---|---|
positiveOrientation
|
bool
|
Set true when orientation is positive, otherwise false. |
required |
__eq__(orientedEdge)
Equal operator
Parameters:
Name | Type | Description | Default |
---|---|---|---|
orientedEdge
|
OrientedEdge
|
Edge to comparison |
required |
Returns:
Type | Description |
---|---|
object
|
True when both edges are equal. |
__init__
overload
__init__()
Initialize
__init__(edgeHandle, positiveOrientation)
Constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
edgeHandle
|
int
|
Set edge handle. |
required |
positiveOrientation
|
bool
|
Set orientation, true for positive, false for negative |
required |
__init__(orientedEdge)
Copy constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
orientedEdge
|
OrientedEdge
|
Edge which will be copied. |
required |
__repr__()
Convert the list to a string
Returns:
Type | Description |
---|---|
str
|
List values as string |