Path
Class full path: NemAll_Python_Geometry.Path
Functions
Clear()
Clear all geometries from path
Count()
Count of geometries stored in path
Returns:
Type | Description |
---|---|
int
|
Count of geometries. |
GetElement(arg2)
Get the element by index
Parameters:
Name | Type | Description | Default |
---|---|---|---|
index
|
Element index. |
required |
Returns:
Type | Description |
---|---|
object
|
Element |
IsEmpty()
Tests whether no elements are present
Returns:
Type | Description |
---|---|
bool
|
True for an empty, otherwise false. |
Remove(position)
Remove geometry at the specified position
Parameters:
Name | Type | Description | Default |
---|---|---|---|
position
|
int
|
Specified position of removed geometry. |
required |
Returns:
Type | Description |
---|---|
object
|
Error code. |
Reverse()
Reverse orientation of the PathElement
__iter__()
Get the iterator