Plane3D
Class full path: NemAll_Python_Geometry.Plane3D
Representation class for 3D plane.
Attributes
Point: Point3D
property
writable
Get 3D Plane reference point
Vector: Vector3D
property
writable
Get the Normal Vector
Functions
CalcPlaneVectors()
Calc X and Y axis vectors for plane
Returns:
Type | Description |
---|---|
Vector3D
|
tuple(Vector of X axis, |
Vector3D
|
Vector of Y axis) |
GetPoint()
Get 3D Plane reference point
Returns:
Type | Description |
---|---|
Point3D
|
Point3D. |
GetTransformationMatrix()
Get transformation matrix for given plane 3D
Returns:
Type | Description |
---|---|
Matrix3D
|
Matrix3D const reference |
GetVector()
Get the Normal Vector
Returns:
Type | Description |
---|---|
Vector3D
|
Vector3D. |
Set(point, normalVector)
Initialize Plane from point and vector
Parameters:
Name | Type | Description | Default |
---|---|---|---|
point
|
Point3D
|
New point. |
required |
normalVector
|
Vector3D
|
New vector. |
required |
SetPoint(point)
Set reference point
Parameters:
Name | Type | Description | Default |
---|---|---|---|
point
|
Point3D
|
New point. |
required |
SetVector(vec)
Set the Normal Vector
Parameters:
Name | Type | Description | Default |
---|---|---|---|
vec
|
Vector3D
|
New vector. |
required |
__eq__(plane)
Comparison of planes without tolerance.
Be careful, this method work without tolerance!
Parameters:
Name | Type | Description | Default |
---|---|---|---|
plane
|
Plane3D
|
Compared plane. |
required |
Returns:
Type | Description |
---|---|
object
|
True when planes are equal, otherwise false. |
__init__
overload
__init__()
Initialize
__init__(plane)
Copy constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
plane
|
Plane3D
|
Plane which will be copied. |
required |
__init__(point, normalVector)
Constructor
Create 3D Plane with given point and vector
Parameters:
Name | Type | Description | Default |
---|---|---|---|
point
|
Point3D
|
Init point of the plane. |
required |
normalVector
|
Vector3D
|
Init vector of the plane. |
required |
__init__(point1, point2, point3)
Constructor
Create 3D Plane from three points which lies on this plane. If plane can not be computed, then constructor throw geometry exception 'Incorrect parameters'.
Parameters:
Name | Type | Description | Default |
---|---|---|---|
point1
|
Point3D
|
1st point on the plane. |
required |
point2
|
Point3D
|
2nd point on the plane. |
required |
point3
|
Point3D
|
3rd point on the plane. |
required |
__init__(axis)
Create a plane from a 3D axis
Parameters:
Name | Type | Description | Default |
---|---|---|---|
axis
|
Axis3D
|
Axis |
required |
__mul__
overload
__mul__(matrix)
2D matrix transformation.
Parameters:
Name | Type | Description | Default |
---|---|---|---|
matrix
|
Matrix2D
|
2D transformation Matrix |
required |
Returns:
Type | Description |
---|---|
Plane3D
|
Copy of transformed 3D plane. |
__mul__(matrix)
3D matrix transformation.
Parameters:
Name | Type | Description | Default |
---|---|---|---|
matrix
|
Matrix3D
|
3D transformation Matrix |
required |
Returns:
Type | Description |
---|---|
Plane3D
|
Copy of transformed 3D plane. |
__repr__()
Convert to string