Polyhedron3D List
Class full path: NemAll_Python_Geometry.Polyhedron3DList
List for Polyhedron3D objects
Functions
__contains__(value)
Check for a value in the list
Parameters:
Name | Type | Description | Default |
---|---|---|---|
value
|
Polyhedron3D
|
Value to check |
required |
Returns:
Type | Description |
---|---|
bool
|
State for value is in the list |
__delitem__(value)
Delete a list item
Parameters:
Name | Type | Description | Default |
---|---|---|---|
value
|
Polyhedron3D
|
Value to delete |
required |
__eq__(compare_list)
Compare two lists
Parameters:
Name | Type | Description | Default |
---|---|---|---|
compare_list
|
Polyhedron3DList
|
List to compare |
required |
Returns:
Type | Description |
---|---|
bool
|
Lists are equal state |
__getitem__(index)
Get a list item
Parameters:
Name | Type | Description | Default |
---|---|---|---|
index
|
int
|
Index of the item |
required |
Returns:
Type | Description |
---|---|
Polyhedron3D
|
Value for the index |
__iadd__(eleList)
Add a list
Parameters:
Name | Type | Description | Default |
---|---|---|---|
eleList
|
list
|
Polyhedron3D list |
required |
Returns:
Type | Description |
---|---|
Polyhedron3DList
|
Lists with the added elements |
__init__
overload
__init__()
Initialize
__init__(ele)
Constructor with a Polyhedron3D
Parameters:
Name | Type | Description | Default |
---|---|---|---|
ele
|
Polyhedron3D
|
Polyhedron3D |
required |
__init__(eleList)
Constructor with a list of Polyhedron3D
Parameters:
Name | Type | Description | Default |
---|---|---|---|
eleList
|
list
|
Polyhedron3D list |
required |
__iter__()
List iterator
Returns:
Type | Description |
---|---|
Iterator
|
List iterator |
__len__()
Get the list length
Returns:
Type | Description |
---|---|
int
|
Length of the list |
__repr__()
Create a string from the elements of the list
__setitem__(index, value)
Set a list item
Parameters:
Name | Type | Description | Default |
---|---|---|---|
index
|
int | slice
|
Index of the item |
required |
value
|
Polyhedron3D
|
Value to item |
required |
append(value)
Append a list item
Parameters:
Name | Type | Description | Default |
---|---|---|---|
value
|
Polyhedron3D
|
Value to append |
required |
extend
overload
extend(iterable)
Add the items from an iterable to the end of the list
Parameters:
Name | Type | Description | Default |
---|---|---|---|
iterable
|
Polyhedron3DList
|
Iterable to add |
required |
extend(eleList)
Extend the list
Parameters:
Name | Type | Description | Default |
---|---|---|---|
eleList
|
list
|
Polyhedron3D list |
required |