Polyhedron Face
Class full path: NemAll_Python_Geometry.PolyhedronFace
Polyhedron face All constructors are prohibited, only Polyhedron3D can instantiate this class. This behavior is dependant on old %Allplan architecture and can be changed.
Functions
AppendEdge
overload
AppendEdge(edgeHandle, positiveOrientation)
Append edge into face
Parameters:
Name | Type | Description | Default |
---|---|---|---|
edgeHandle
|
int
|
Appended EdgeHandle. |
required |
positiveOrientation
|
bool
|
True for positive, false for negative orientation. |
required |
AppendEdge(edge)
Append edge into face
Parameters:
Name | Type | Description | Default |
---|---|---|---|
edge
|
OrientedEdge
|
Appended Edge. |
required |
AppendEdges(edges)
Append edges into face
Parameters:
Name | Type | Description | Default |
---|---|---|---|
edges
|
OrientedEdgeList
|
Vector of edges. |
required |
GetEdge(edgeIndex)
Get the edge index on specified position
Old interface: getFaceEdge
Parameters:
Name | Type | Description | Default |
---|---|---|---|
edgeIndex
|
int
|
Specified position in edge vector. |
required |
Returns:
Type | Description |
---|---|
tuple
|
False when edgeIndex is out of range or when occurred another error, otherwise true., |
tuple
|
Edge index. |
GetEdges()
Get the edge index on specified position
Returns:
Type | Description |
---|---|
OrientedEdgeList
|
Vector of oriented edges. |
GetEdgesCount()
Get count of edges
Old interface: getFaceEdgeCount
Returns:
Type | Description |
---|---|
int
|
Count of edges. |
GetFlags()
Get the flags of the face
Returns:
Type | Description |
---|---|
int
|
Face flags. |
SetFlags(flags)
Set the flags of the face
Parameters:
Name | Type | Description | Default |
---|---|---|---|
flags
|
int
|
Face flags. |
required |
__getitem__(edgeIndex)
Get the edge index on specified position
Method can throw exception when index is out of range. Please use the GetEdgeIndex with return flag when you do not used exception handler. Old interface: getFaceEdge
Parameters:
Name | Type | Description | Default |
---|---|---|---|
edgeIndex
|
int
|
Specified position in edge vector. |
required |
Returns:
Type | Description |
---|---|
OrientedEdge
|
Edge index, not reference. |
__init__(face)
Standard copy constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
face
|
PolyhedronFace
|
|
required |
__repr__()
Convert the list to a string
Returns:
Type | Description |
---|---|
str
|
List values as string |