Polyhedron Type
Class full path: NemAll_Python_Geometry.PolyhedronType
Bases: IntEnum
Type of polyhedron visual representation
tEdges : Polyhedron has a edges only. tFaces : Polyhedron has a faces. tVolume : Polyhedron has a volume.
Attributes
tEdges = 1
class-attribute
instance-attribute
tFaces = 2
class-attribute
instance-attribute
tInvalid = 0
class-attribute
instance-attribute
tVolume = 3
class-attribute
instance-attribute
Functions
__getitem__(key)
get the item for a key
Parameters:
Name | Type | Description | Default |
---|---|---|---|
key
|
str | int | float
|
value key |
required |
Returns:
Type | Description |
---|---|
PolyhedronType
|
value for the key |