Polyline3D
Class full path: NemAll_Python_Geometry.Polyline3D
Bases: PolyPoints3D
Representation class for 3D Polyline.
Functions
GetLine(index)
Extract a line
Parameters:
Name | Type | Description | Default |
---|---|---|---|
index
|
int
|
Index of the line |
required |
Returns:
Type | Description |
---|---|
Line3D
|
indexed line |
GetLines()
get lines from polyline
Returns:
Type | Description |
---|---|
Line3DList
|
lines |
InsertPolyline(polyline, position=18446744073709551615)
Insert another polyline at given position
Parameters:
Name | Type | Description | Default |
---|---|---|---|
polyline
|
Polyline3D
|
Polyline to be inserted |
required |
position
|
int
|
Position where the polyline has to be inserted |
18446744073709551615
|
Returns:
Type | Description |
---|---|
bool
|
true if successful |
IsPlanar()
Check if polyline is on one plane
Returns:
Type | Description |
---|---|
bool
|
tuple(True if polyline is on one plane, |
Plane3D
|
if polyline is on one plane the plane is calculated) |
IsValid()
Check if the polygon is valid ( has at least 2 points )
For additional point validation use Service::Validate.
Returns:
Type | Description |
---|---|
bool
|
true if is valid |
LineCount()
Get the count of lines connecting the points
Returns:
Type | Description |
---|---|
int
|
count of lines |
Reverse()
Reverse Polyline orientation
__eq__(polyline2)
Equal operator
Parameters:
Name | Type | Description | Default |
---|---|---|---|
polyline2
|
Polyline3D
|
Second polyline |
required |
Returns:
Type | Description |
---|---|
bool
|
Polyline3D are equal |
__iadd__
overload
__iadd__(polyline)
Additional assignment operator
Parameters:
Name | Type | Description | Default |
---|---|---|---|
polyline
|
Polyline3D
|
Polyline which will be added to current polyline |
required |
Returns:
Type | Description |
---|---|
Polyline3D
|
Reference to polyline |
__iadd__(point)
Addition assignment operator
Parameters:
Name | Type | Description | Default |
---|---|---|---|
point
|
Point3D
|
New Point3D which will be added to the polyline |
required |
Returns:
Type | Description |
---|---|
Polyline3D
|
Reference to polyline |
__iadd__(line)
Addition assignment operator
Parameters:
Name | Type | Description | Default |
---|---|---|---|
line
|
Line3D
|
Line3D which will be added to the polyline |
required |
Returns:
Type | Description |
---|---|
Polyline3D
|
Reference to polyline |
__init__
overload
__init__()
Initialize
__init__(pntList)
Constructor with an initializer list
Parameters:
Name | Type | Description | Default |
---|---|---|---|
pntList
|
list
|
Point list |
required |
__init__(polyline)
Copy constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
polyline
|
Polyline3D
|
Polyline which will be copied |
required |
__init__(polyline, skip, count)
Copy constructor with limited scope
Parameters:
Name | Type | Description | Default |
---|---|---|---|
polyline
|
Polyline3D
|
Polyline which will be copied |
required |
skip
|
int
|
count of points ignored at start. |
required |
count
|
int
|
count of points copied. |
required |
__init__(points)
Vector points constructor.
Parameters:
Name | Type | Description | Default |
---|---|---|---|
points
|
Point3DList
|
Vector of points which will be moved to polyline |
required |
__mul__(matrix)
Multiple Polyline with matrix
Parameters:
Name | Type | Description | Default |
---|---|---|---|
matrix
|
Matrix3D
|
Transformation matrix |
required |
Returns:
Type | Description |
---|---|
Polyline3D
|
Transformed polyline |
__ne__(polyline2)
Not equal operator
Parameters:
Name | Type | Description | Default |
---|---|---|---|
polyline2
|
Polyline3D
|
Second polyline |
required |
Returns:
Type | Description |
---|---|
bool
|
Polyline3D are equal |
__repr__()
Convert to string