Sweep Rotation Type
Class full path: NemAll_Python_Geometry.SweepRotationType
Bases: IntEnum
Type of the sweep rotation
Attributes
Locked = 0
class-attribute
instance-attribute
RailLocked = 2
class-attribute
instance-attribute
Unlocked = 1
class-attribute
instance-attribute
Functions
__getitem__(key)
get the item for a key
Parameters:
Name | Type | Description | Default |
---|---|---|---|
key
|
str | int | float
|
value key |
required |
Returns:
Type | Description |
---|---|
SweepRotationType
|
value for the key |